Zonin won't install on Lenovo B575

Beginner - new to Linux (done with Windows - switching business & personal machines to Linux)

Computer: Lenovo B575 laptop (Intel BIOS ONLY, NO EFI/UEFI; VERY FEW BIOS SETTING OPTIONS)

OS: Zorin 16.1 Core or Lite
Installation: Dual-boot w/Win7 or solo

After creating some partitions to dual-boot w/Win7 32-bit, Zorin will install successfully until GRUB which fails and will only boot to: GRUB _

Tried solo installation on bare drive in machine with same failure.

Various posts suggest that the BIOS was "Optimized" by Intel for Windows and thus cause this problem. I found a workaround post but could not follow it.

Zorin installed perfectly on 2 other personal machines. Windows App Support is very helpful!

I'll appreciate any help! Thanks!

Tom

This confuses me...
Windows is 32 bit? Is it a 686 machine?
Or 32 bit?

Zorin OS 16 is only available in 64bit. As most Linux distros are now, too. Zorin OS 15 Lite is still available as 32bit.

I initially had this issue before, but I found the solution myself. See here :arrow_down:

Hope this helps.

3 Likes

I googled the specs on that it looks like most came with an AMD E E-350 1.6 GHz or similar which do support AMD64. Looks like it only comes with 2gb of DDR3 RAM though.

That might be a candidate for tinycore linux

2 Likes

The Lenovo B575 is a 64 bit machine. I installed Win7 32-bit to run some old programs which we could not get to install on 64-bit Windows, even with its "compatibility solution". (Those same programs run fine on Zorin's Win App Support on other computers.)

1 Like

I just did a quick search on this machine for Ubuntu Installation troubles and... comes up with a lot of hits. Most dating from Ubuntu 14.04.
Here is one example:

I would guess that given the locked down BIOS settings on that machine, combined with its age...
It's going to resist many distros.
Have you tried Antix Linux or MX Linux?

I'm trying Zorin on our personal PCs in hope that we will be able to use it (Pro) on our business PCs as well.

Following partitioning directions in another Zorin post, I was able to install Zorin successfully on this laptop (I think) until the very end when GRUB installation failed and it would only boot to: GRUB _

GRUB Rescue did not help.

Since I'm working on a cloned copy of my daughter's original HDD, I can experiment on the copy.

Another reply in this post suggested Super GRUB 2 so I'll explore that and post my results.

1 Like