Zoom Won't Open Twice

Hi! I'm new to Zorin OS and have run into some trouble getting the Zoom application to work on my device. I've tried installing from the Software Center, directly from Flathub, and from Snapcraft--no version of Zoom seems to work properly. When I first open the app, Zoom opens and allows me to login in and begin a meeting. After I close the open window for Zoom, I cannot re-open the application until I reboot the computer (i.e., nothing happens when I click on the Zoom application). Does anyone have any idea what's going on?

I would remove any install you have and get the official download from here:

Choose Ubuntu and 16.04+ version.

This should download a .deb package, then use gdebi package installer to install it. If you don't have it install gdebi using Synaptic Package Manager. Gdebi informs you if there are any missing dependencies at point of install. A more secure platform is https://meet.jit.si
All you need is a browser that supports Chrome extensions and it works in Firefox. Can also be synced with Google and Outlook calendar.

1 Like

OK. Thanks for the suggestion. I've tried installing that .deb package using gdebi, but I'm still encountering the same error--Zoom opens once, but after I close the app, it won't re-open. Anyone have any other ideas?

I suspect in part it is because Zorin is based on Ubuntu 20.04. I'm always dubious of applications that offer a package that is compatible with Ubuntu 16.04 - I had a different application I needed for work when I was running Feren OS and that had same Ubuntu level. Feren OS was based on 18.04 at the time. I would ditch Zoom for https://meet.jit.si Ypu need to enable encryption if needed before starting a meeting. If the meeting needs to be recorded then you have to have encryption disabled for obvious reasons. I was in constant contact with a work colleague whilst working from home and never had any downtime. I also used it to help a retired nurse in Florida restore her Windows 10 machine and I'm in the UK, purely using chat as she didn't have a camera! And that was about four hours with no disconnects (apart from when I made an error!)

1 Like

I guess the other option is to run Zoom from within your webbrowser of choice. But is not the best experience.

1 Like

Never had issue with Jitsi in browser. It always worked and persuaded colleagues who had returned to work to use it over Teams if they wanted my participation. Far superior to Teams - their GNU/Linux offering was appalling, but no surprises there. My system reported its true name, 'Skype for Business'! LOL!

I discovered a workaround, but it's not a convenient long-term solution. It looks like what's happening when I close Zoom is that all of the processes from the app continue to run in the background even though the app was closed. So, when you try to open the app again, the computer believes that the app is already open. If you kill those processes in System Monitor (or restart the computer), Zoom opens properly.

Thanks for the suggestion about Jitsi! I'll definitely try it for personal use, but I unfortunately I work at a school where I will need to have access to Zoom. Does anyone know how one might go about fixing this issue? Is there a way to automatically kill processes when you close an app?

Killing the processes from terminal also works as a temporary fix.

I know how to make it easier for you to be able open Zoom twice after you close the Zoom once.

First, never close your Zoom app using the Close button.

Second, instead closing it using the Close button, you should Exit from Zoom through the System Tray on the bottom right. And then choose
Exit, not Sign Out. Using this method will allow you to open and close Zoom as many times as you like.

I hope this method is useful.

1 Like

This works! Thank you. This method does automatically end the processes in System Monitor as well. Evidently, the problem with the Zoom app is only with the Close button.

1 Like

So glad it works on your problem too.