Zorin 15.3 core shows black screen after restart

Hello, today I installed zorin 15.3 core and it went fine, but after the installation finished and I restarted my pc it got stuck on the zorin os logo while shutting off.
Because of that I restarted again but this time only a black screen with blinking white line appeared, I couldn't find a solution online.
Can someone help me find a solution please ?

(English isnt my first language so sorry for grammer, also I'm new to linux so sorry for dumb question if it is)

Welcome to the forum.
You might want to check this posting by me:

Okay, so if I disabled CSM it just redirected me to BIOS,
then I switched the boot order and it worked, it booted fine, BUT after I restarted my PC to check if its fixed I got the same problem.
I tried both solutions again but now I get a moving lines across the borders, three blinking white lines and then blank black screen.

Did you install Zolin in EFI mode or legacy mode?
The method I described is for EFI installation.

I have no idea which way I did, I just burned an image on a flash drive, booted my pc on it and installed. How do I know which one I did ?

How did you create installer USB? If using Rufus, there is an option for EFI and Legacy mode. It is better to install Zorin in EFI mode if your system can take it.

I didn't use Rufus, I used etcher and I dont think there was an option to chose which one.
So should I re-install zorin but this time using Rufus and EFI mode ?

It is a consensus among the majority of the regular members here that Etcher could be problematic - I myself had 2 USB keys corrupted by Etcher. I usually use Rufus in Windows and Mintstick in Linux.

You could disable CSM in BIOS and try installing one more time. If that fails, remake installer using Rufus/Mintstick.

Okay, I think I'll just use Rufus this time, should I change the CSM setting for that ?

No, it is not necessary. It only concerns when you install Zorin.
One more thing I have to ask you. Are you trying to dualboot?

Okay, as for the question, no I'm not trying to dualboot.

Ah, good. It will be much simpler then :slight_smile:

While trying to boot from my flash drive an image poped up saying that in trying to boot using the Legacy option while my flash drive is using EFI. Should I disable CSM or change its "Boot device control" to "UEFI only" ?

Yup.
You should disable CSM.

Okay it works now, Ill try to install, thank you.

Okay, i installed and it went fine.
But after the installation I restarted my PC and I entered my encryption password it told me that it was successful but then the 'ZORIN' logo stucked and nothing happend, any ideas ?

I am afraid I cannot help you regarding an encrypted file system since I've never used an encryption in Linux.

I hope someone like @Aravisian or @Storm could help you since they have a way more experience in Zorin OS than myself.

[Edit]
You could also try installing Zorin 16 Core. many problems were solved in this latest version of Zorin. I have been using it in my production environment without any issue for quite sometime.

I would appreciate all the help I could get.
As for the Zorin 16, I'll try but I believe that the problem is in my settings or something that I did wrong.

Even just to preclude such possibility, it is worth while to test out a different version. This can help you to nail down the cause of the problem.

1 Like

What is the year make and model of the machine - what graphics card are you using?
This sounds like a graphics issue.

1 Like