Zorin 15.3 wifi trouble

i have not tried to disable ipv6. i will try that today

1 Like

Can you try searching in Synaptic Package manager for
And see what comes up? Please relay those results, here.

will try tomorrow. thanks.

looks like nothing comes up

and when i search for just linux headers, it only goes to 5.4.... which are installed

i'm getting the feeling that this is going down a dead end. ubuntu 18... is just not going to support the newer wifi hardware. it seems like ubuntu 18/zorin 15 are maxing out at kernal 5.4...

Please open your ~/Downloads folder and make a new folder named kernel within it.
Download these .deb packages for the 5.8 kernel and place them inside your newly created kernel folder:




Open a terminal and Change Directory to the kernel folder:

cd ~/Downloads/kernel

Install the packages:

sudo dpkg -i *.deb

1 Like

you are awesome! that was it. kernel needed to get up to 5.8. man, thanks for all the help and sticking with me.

1 Like

i have quite a few other computers to do that too, will doing just the 5.8 kernal work for getting the wifi working or do i need to do that and the driver update from earlier in the post?

It's hard to say... It depends on the hardware. Are all the computers the same year, make and model, same wifi card??

they should be. i'm running those tests.

1 Like

ok. so the driver from the beginning of this first post didn't work with the kernal update and i didn't try any different way, i just moved on to try something else: zorin was trouble shooting with me earlier in this process and gave me a link to linux drivers. so my process for the 2nd n4020 was:
run the software updates, reboot
run the kernal update from Aravisian
run the drive update from zorin, which i will put in the next post wit their directions.

From Zorin:
Please try following these steps:

Download the following file from another computer onto a USB drive:


Open the Files app in Zorin OS and navigate to the Downloads folder, where the "linux-firmware_1.187.17_all.deb" file should be.

Right-click on an empty space in the folder where this file is and select the "Open in Terminal" option

Enter the following command into the Terminal: sudo dpkg -i linux-firmware_1.187.17_all.deb

Reboot your computer to apply the changes.

Afterwards, you should now be able to connect to Wi-Fi networks from the Settings app.

what i just found out on my newest test is that the order of driver updates or kernal updates does not matter. the wifi worked regardless of which order those 2 updates were done. i have tested on 3 different n4020s already and all got their wifi back again. thanks for the help!


i was also having this wifi trouble on one minisforum gk50 that i was testing. i just put it on xubuntu and didn't think about it, but now i've gone back and tested it with the solutions from above with zorin 15.3 lite and this got the wifi working for that model as well.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.