Zorin 15.3 wifi trouble

i have been using zorin 15.3 lite on the minisforum n40 but that model n40 has been discontinued and the n40(20) is now what's out there. i bought a few and then tried to use 15.3 lite but the wifi isn't working. the wifi shows up as a network choice, but no networks show up in the network list and i know there are about 20 that i can see at my house. and the networks aren't the problem, i have the old n40 right beside this new n40(20). one of the changes was the wifi card on the new n40, so i assume that's the problem. also, zorin 16 works fine with my wifi. this is the true reason that i think the newer wifi card in the new n40 is the problem. and i've been in contact with zorin support and they sent me a few links to install new drivers but nothing has worked so far. and i don't need - just move to zorin 16. i use the xfce flavor and gnome does not work with my workflow. and i know zorin 16 lite is coming at some point, but it's not here yet so i have 5 computers that don't work in my system at the moment. so that is my goal here - getting the minisforum n40(20) to work with zorin 15.3 lite. here is my wifi info from the n40(20):
*-network UNCLAIMED
description: Network controller
product: Realtek Semiconductor Co., Ltd.
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: ioport:e000(size=256) memory:c1100000-c110ffff
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 15
serial: 84:47:09:06:ef:aa
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.47 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
resources: irq:23 ioport:d000(size=256) memory:c1004000-c1004fff memory:c1000000-c1003fff

thanks

Another option would be to move to Zorin OS 16 core, then install XFCE on it (Which is what I did. I am not that patient.)

i have a zorin 15.3 lite clone that is prebuilt with all the things i need and right now i don't have the patients to go through a clean install and make all the adjustments i've made over the years. and i don't want to miss anything i don't remember tweaking. the clone works perfect except for not working with the newer wifi hardware i'm hoping someone has been able to update the drivers to work with newer wifi adapters on 15.3.

Please download the driver from me, here:

It should now be in your Downloads directory.

Extract it, then open a terminal in the directory or use the cd command to change directory:

cd ~/Downloads/r8168-8.049.02

Then run the installer:

./autorun.sh

I did not know anything about this product.

It is so small and compact.
Is it sold without OS?

not that i know of. i buy it with win10 and then just put zorin on it. it runs not great with windows, but great with zorin.

1 Like








that didn't work on this try. i did screen grabs of the results. and also that i see the wifi hardware but no networks. then i did a screengrab of a computer next to it, to show a bunch of networks i can see. and this has been the case before i started any trouble shooting - wifi is a choice in my networking, but no networks show up. i am also going to try wiping this n40 out and then starting over with your drivers. i tried a bunch of other things from the zorin guys that didn't work, so i don't know if there is any conflict there.

Looking at its spec, I can believe you.
Linux is way more resorce efficient than Windows :slight_smile:

There is always a USB WiFi option (starting from something like 5.99 Euro). The modules below have been tested by your trusted Maid-bot :robot:

not the solution i was looking for

I understand. I just show you the last option when everything else fails.

thanks. i can move to zorin 16. i can use xubuntu. i can just plug in hardline. i have tons of options, but i'm not looking for options. i'm trying to find a solution to this one problem. the n4020 works with zorin 16 fine, so it's a driver problem with 15.3. that's what i'm trying to get help with. hopefully someone has solved the driver problem for 15.3 running that specific wifi card.

1 Like

Any specific reason you do not want to go for Zorin 16?
I saw many users solved the driver issue by upgrade to Zorin 16 on this forum.

2 Likes

This implies it may be due to Zorin 16 having a Higher Kernel.
I would need to follow up on this and check the literature on that device.
But off hand, which kernel is running on your Z15 build?

System: Host: zorin-clone Kernel: 5.4.0-86-generic x86_64
bits: 64 gcc: 7.5.0
Desktop: Xfce 4.14.2 (Gtk 3.22.30) Distro: Zorin OS 15.3
Graphics: Card: Intel Device 3185 bus-ID: 00:02.0
Display Server: x11 (X.Org 1.20.8 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 600 (GLK 2)
version: 4.6 Mesa 20.0.8 Direct Render: Yes

i have a work clone of 15.3 that has a ton of modifications and xfce is what i need to do that. so no gnome. i will upgrade to 16 lite when that is available, but i've been told that's "months" away. so i'm trying to get a handful of n4020s to not be paperweights until then by trying to solve this wifi/driver/kernal issue. i may never get it solved to work with 15.3, but i wanted to try. right now those computers are just set aside. i can install xubuntu on them in an emergency, but zorin is still my favorite desktop.

I wonder if @Aravisian might have some idea saving those modifications for easy reinstallation. He is our XFCE specialist volunteer.

Have you disabled ipv6?

I am not sure if this will work on 15.3, but it is worth a shot:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic