Zorin 15 Freezes on Suspend

I use Zorin 15.3 core on my laptop daily and it recently came to my attention that on closing the laptop lid, Zorin freezes and I cannot do anything, forcing me to force shut-down my laptop. I also noticed that even the LEDs on my mouse are not lighting up. I looked up on the internet but I didn't find any useful information. This is a deal breaker for me as not being able to close the laptop lid is kind of a big deal for me... especially when I need to move around. Does anyone know what might be causing this and how to fix it? I can provide more details if needed.

Have you tried:

sudo nano /etc/systemd/logind.conf

Look for the following:

#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore

Change them to (remove the hastags, too)

HandleLidSwitch=ignore
HandleLidSwitchExternalPower=ignore
HandleLidSwitchDocked=ignore

Otherwise, can you post the contents of /var/log/kernel.log?

But doesn't this totally remove the suspend when lid closed feature? I still want the feature, just not the whole crashing part.
Kernel log (although it was called kern.log): Github Gist

I understand and that makes sense.

Determining some things can get to the point of a needle in a haystack. It is always preferred to Solve the Problem than to use a workaround. A workaround may be either all you have to keep your wits OR it may be a Temporary thing until a solution is found.
That being said; sometimes applying the workaround and seeing whether it works or does not work can give a needed clue for troubleshooting the issue.

EDIT: In your grub default, do you have acpi=off?

Do you use Nvidia Graphics card?

1 Like

It doesn't exist in the grub.cfg file. I don't know what it defaults to.

Yes I do. But the integrated Intel GPU is used to render all the OS GUI, etc.

Edit: I just tested it out and it is not just with closing the lid. The Suspend command freezes the PC.

I think the drivers for Nvidia may be playing a role.
Can you

sudo nano /etc/default/grub

add this parameter nouveau.modeset=0 to the line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
So that it reads:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

Exit, Save and reboot to test...

I tried it and it didn't work. Still freezes.

Would it be of any use sending the contents of the Logs application?

I saw that you are using nouveau drivers in your log.
But you may try

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Be sure to run

sudo update-grub

afterward.

Usually upgrading the kernel resolves this issue. However, since you are on kernel 5.4, that just does not seem likely to me.
The other common culprit is the Nvidia Drivers in use at the time of suspend.

You can try changing your Nvidia or Nouveau drivers -
You can try the following grub boot parameters (same procedure as above; add them to the line after quiet splash followed with the closing quotation mark - " - )
GRUB_CMDLINE_LINUX=
"nouveau.blacklist=1"
"acpi_osi=!"
"acpi_backlight=vendor"
"mem_sleep_default=deep"
Or, try them all at once:

GRUB_CMDLINE_LINUX="quiet splash nouveau.blacklist=1 acpi_osi=! acpi_backlight=vendor mem_sleep_default=deep"

sudo update-grub

Yeah that sadly didn't work as well.
I just booted up Zorin 16 on a flash drive and suspending the system didn't crash it. So I assume it is kernel related. Although I haven't tried suspending the system on a Zorin 15.3 flash drive yet.

1 Like

I'm having the same "suspend" problem running Zorin 15.3 Lite on a Dell D630 system with Nvidia Quadro NVS 135M graphics. Zorin installed the proprietary Nvidia 340.108 driver which seems to be the most up-to-date driver available. The Linux kernel is version 5.4.0-73-generic is that is significant. Like many others have reported, the screen remains black after waking up from suspend. It APPEARS that the system itself wakes up (WiFi light flashing, mouse lights up) but the screen remains black.

I've tried just about all the suggestions for fixing this problem, but so far nothing has worked. I'm hoping that perhaps Zorin 16 Lite (when available) may finally fix this widespread problem, but in the meantime it seems necessary to shutdown & restart the system instead of trying to suspend it... Wayne

1 Like

I just found a set of Power Manager settings that will allow the system to suspend AND THEN WAKE up! I set the Power Manager > General setting When power button is pressed to Do nothing and the When laptop lid is closed settings to Suspend. Now, when the lid is closed the system will suspend. More critically, after opening the lid, tapping the power button will wake up the system! (Tapping any other key or moving the mouse will NOT wake up the system.)

The critical setting seems to be Do nothing when the power button is pressed. Any other setting for that button seems to interfere with the wakeup process.

Hoping this info may prove useful to other users - Wayne

3 Likes