Zorin 16.1 pro haveing graphical UI issues (ROG STRIX G17)

So for Zorin 16 I had none of these problems but I got the Zorin pro 16.1 version so I do not want to go back and I do not have the old 16 ISO anymore.
My PC is a ROG STRIX G17

Problem 1: Sometimes when I close my laptop lid and I open the lid I get a flashing underscore icon on the top left and no matter what different key combination I use nothing happens so I am forced to restart.

Problem 2: Same thing as problem #1 except sometimes instead of getting a flashing underscore I get a tty3 window and sometimes my keyboard input is not seen or working at all so I am forced to restart.

Problem 3: So this is not as important but in Zorin 16 My RGB rainbow option is supposed to be moving and in Zorin 16 it has been but in 16.1 the RGB rainbow is static and no matter what I do it will not move no more. At least the keyboard lighting in the settings works though :slight_smile:


This relates to your issue posted above.

I do not see how this would be a kernel issue or how this post relates to the kernel problem or that post. I am honestly lost on your reply.

The kernel is a set of drivers. The issues you describe sound like a later 5.13 kernel issue to me.
I would recommend rolling back to the previous working kernel that you had before the update.
I linked your other post to assure you that rolling the kernel back will not affect your ability to run updates and upgrades.

my bad I should have payed attention, thank you for your help.

I have tried a different kernel like the one from the guy recommended me and I still have the same problems and my keyboard lighting does not work but i can update.

what was the kernel that Zorin 16 had not 16.1?

I have been trying different kernels but my keyboard lighting has not worked for any of the 3 I have teasted so far.

I think what comes on the .iso would be 5.13.0-27

We can test it:

sudo apt install linux-headers-5.13.0-27-generic linux-modules-5.13.0-27-generic linux-modules-extra-5.13.0-27-generic linux-image-5.13.0-27-generic

On the keyboard; I use OpenRGB for all the Computer lighting and have had no problems with it; no matter which kernel I use.
I wonder if that may be an option for you.
You can use PPA:

sudo add-apt-repository ppa:thopiekar/openrgb

sudo apt update && sudo apt install openrgb

Or the appimage obtainable from their website:

open RGB does work and the older kernel did not do anything different. I still close my laptop lid and I have the same problems. Thank you for trying to help me but I really do not think this is a kernel problem. What else could it be though?

While the kernel is not the only thing that has changed or is different between Zorin 16 and Zorin 16.1 (including Pro); it is the only central thing that can affect each of what you are describing.
Are you certain that you booted into the Earlier kernel rather than default booing into the latest installed kernel?
In the meantime, I will try going over the changes between and see if I spot anything else. It may take some time...

I can give you my word I booted to the 5.13.0-27-generic kernel. lighting works but UI same problems. That is the only problem I am facing with Zorin 16.1 pro.

Ok, so that fixed the Keyboard backlighting, but not the Wake from lid sleep or suspend?

the keyboard lighting stayed the same in general of it is working and thanks for the open RGB thing because I have more options for my lighting now. however the wake from lid or sleep from suspend problem was still there. Besides the kernel I have 2 other kernels that came with the Zorin 16.1 Pro operating system and that is kernel and kernel and those did not fix the lid problem.

I have noticed though that the kernel has more things sported
on it though so you think it would fix the problem but it does not.

I know the screen shot shows I am running kernel 5.13.0-39 when normally I run kernel I just forgot to select that option when I booted up.

I am on ROG strix G15, updated to Kernel 5.16 some time ago and have not experienced any issues whatsoever.
I messed my system up couple of days ago - own tinkering.
Put a fresh install of Zorin on my laptop, did Kernel upgrade to 5.16.15 right away and no issues once again.

1 Like

So your keyboard lighting works just fine still?
I will test out your kernel you are running and edit this reply after I test it so share if this fixed my problem or not. :slight_smile:
EDIT: so the 5.16.15 kernel did not help and my lighting does not work and sudo apt update (or nala same thing but I tested both) did not want to update my system and I got a red ! mark in my taskbar saying had problems updating.

That and my NVIDIA setting had less options then before even with the correct drivers installed otherwise I have so much more options then this normally but as normal a newer kernel fixes my blue-tooth problem lol.

EDIT #2: Ok when I did the update I had no internet because my house has been having problems so the sudo apt update command not working was my fault.

So, after properly updating, the same problem persists on the 5.16 kernel?

ya it does and it has got to the point were I reinstalled zorin but now I have a more worrying problem. The NVIDIA app control thing is not on my system anymore and all I did so far was do a sudo apt update && sudo apt upgrade. My options are greyed out now. I am having really bad luck with zorin 16.1

at this point I am just having so much bad luck with my computer using zorin 16.1 pro on my computer I am happy I supported you guys by getting the pro version but I just want Zorin 16 back even if it is core because at this point I just want my working system back. I had no UI or driver problems with 16. I will eventually switch if I still have these problems though, again thank you everyone helping me out


sudo ubuntu-drivers install

This sentiment makes a lot of sense to me.
I know I would be banging my head on the wall.

The only issue I am having is that the differences between 16.1 Pro and Zorin OS Core 16 should not account for any of this.

You might try using the Nvidia drivers that I use:
Add the repo:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Then upgrade, again

sudo apt update && sudo apt upgrade

I will test this however after doing the sudo ubuntu-drivers command this has helped me so now I have it back and this is what it looks like.

after adding the repo I am back to normal with what it is telling me.

1 Like

The UI lid closing thing is now solved as I have been testing it vigorously and my PC is working normally now with everything including the NVIDIA driver problems I have been having is solved after a fresh install of Zorin.

I want to but can not say for certain that installing NVIDIA CUDA and messing with drivers as in installing all the drivers available and messing with kernels in general caused my UI problems and GPU problems.

Solution I have come to: Just back up the things you need and reinstall zorin and just do these things as this has worked for me and could work for anyone else having these problems.

Step 1: reinstall Zorin
Step 2: sudo apt update && sudo apt upgrade
Step 3: sudo ubuntu-drivers install
Step 4: sudo add-apt-repository ppa:ubuntu-x-swat/updates
Step 5: sudo apt update && sudo apt upgrade

Just for good measure even though it is probably not necessary because Linux but just reboot your PC and everything should work fine now.

1 Like

I have often found this, as well.
We like to learn and test on our machines, but on occasion, it was not the right move; sometimes, we are not sure which move was not right.
Sometimes, we do not remember all that we did...
I have noticed that the majority of users resist the idea of a fresh install. In some cases, where their setup required the installation of some extensive or tricky packages, this makes sense.
But for most people, a clean install works wonders.

1 Like