Zorin 16.2 goes to sleep immediately after start

Hi, really love the interface coming from long term Elementary and Ubuntu user. Kudos to the team for great work!!

Just facing one problem:
I am using laptop in desktop mode - always plugged in and monitor/keyboard/mouse connected using a docking station. So my laptop lid is always closed and start using power button on docking station.
The system starts fine, and goes into sleep immediately after login, I have to press the power button again and then it's all good.

I tried following solution with no luck:

Have you confirmed it's the lid? If you start with the lid open, does it stay on?

If it's not already installed, do:
sudo apt install gnome-tweaks

Run: Zorin menu > System Tools > Startup Applications

-- or --

Run: gnome-tweaks
Navigate to 'Startup Applications' side tab

If it's not already there and enabled, add:
Name: ignore-lid-switch-tweak
Command: /usr/lib/gnome-tweak-tool/gnome-tweak-tool-lid-inhibitor
Comment: Ignores laptop lid switch.


As Mr. Magoo suggested, and yet there is a more simple way for use on dockingstations. Open Terminal --> Ctrl + Alt + t (copy / paste following command)

sudo apt install gnome-tweaks -y

Close the terminal and click on the Z of Zorin menu, type in the search field tweak and click on the tweak-tool app.
This opens a screen with the following (see screenshot , note: my version is in Dutch ... so your version will be in your systems language)

So really it is on the Left side the first option and on the right side the second option you'll have to turn OFF (suspend when lid is closed).

Close after the setting all screens and reboot. Test the new setting tweak on your docking station by turning on the laptop and see if it remains ON .

On my docking - Dell E6510 - Zorin Core 16.2 this option runs fine or flawless. I use this a lot of times. And when travelling short I switch again the option for quick wake on suspend when I need it. Long story for a small action you need to do .

Thanks all. Got this work by changing logind.conf

What exactly did you change there? This can be useful for others with the same problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.