Zorin 16.2 install problem

Hi, running into an issue trying to install Zorin 16.2 on an IntelNUC11PAHi5.

Secureboot is disabled. Multiple USB's used, multiple download images of 16.2 used and USB BalenaEtcher and Rufus (current versions) used. The NUC installs LinuxMint fine. Zorin 16.2 goes to a black screen with all combination of USB, ISO and USB creation tool when I pick Install/Try using normal, safe, nvidia drivers - it doesn't even start the check routine.

USB verified working on another machine and a VM - so pointing towards the installer and NUC video card?

Any ideas?

Does this sound similar to this post?

Yes - some similarities for sure .. :weary:

The O.P. in that thread noted that the 16.1 version installs just fine.
Once installed, you need only run

sudo apt update && sudo apt full-upgrade

to upgrade it to version 16.2

Tips to fix-

Check the integrity of the USB Install Drive and the downloaded .iso file.
Connect to the Internet before installing Zorin OS.
Disable Fast Startup and Fast Boot.
Disable Secure Boot.
If the installer doesn't recognize the computer's hard drive/SSD.

Rachel Gomez

I think there is a bug in the installer better to install zorin 16.1 first and then update to the latest version as @Aravisian said above

@AZorin @zorink, maybe recheck the iso's ?

thanks - I used the same 16.2 USB on a VM on another computer and it installs perfectly fine

ISOs are fine as the USB installs on another VM/PC fine. The issue appears to be when the installer starts the zorin integrity check - perhaps it's the graphic splash/video mode?

Update: tried 16.1 and it fails at the same point - tried Linux Mint 21 Cin using same process and same USB3 stick and it installs. Verified my 16.1 on a different PC and installs fine.

Is there anyway to skip the Zorin integrity test as the Zorin graphic splash seem to cause my issue (I don't get the screen to choose CTRL+C to skip)

That NUC uses integrated graphics from Intel so you should not need Nvidia drivers...as far as I know. I did not find anywhere in the Intel specs where they are using an Nvidia graphic chip but, maybe they are.

Have you disabled integrated graphics and, are you using a M.2 type graphics adapter?

It's just using the standard NUC graphics / HDMI out.

Re-install with out selecting Nvidia graphics and see what happens. I don't think the Intel integrated graphics are Nvidia...I may be wrong though. Even if the integrated were Nvidia it should not matter as I don't think the CPU/GPU will let external graphic drivers interfere with the integrated chip.

Here is the Intel spec sheet for your NUC...


I can't try/install - that's the problem :slight_smile: the screen goes blank as soon as I choose to start Zorin 16.2 with any of the 3 options (normal, safe, nvida).

I think I could be waiting for 16.3 :frowning:

OK ... yeah, I missed that about the Normal install attempt. Here are some links for NUC and Linux installations. Take a look at them, the second link has some info about Ubuntu drivers. These links are mostly for after you have a good install however, someone here may be able to suss out some information that may be of use to you.

Linux Support for NUC

How To Find Graphics Drivers For Linux

That above is mostly above my level of knowledge however, I will take a guess, slightly uneducated and say that Zorin is attempting to install as VGA and looking for the standard VGA adapter. You are using HDMI and that may be causing your issue.

edit: Well, you board may or may not support Linux. I am not clear if the below information is hard and fast or simply user reported.

Linux Support

F2 gets you into the BIOS during boot, have you taken a look at the BIOS settings. Safe boot set to off?

Yeah sadly the new NUC must be too obscure for Zorin which seems nuts :frowning:

Also, FWIW I tried kernel boot parameters removing nosplash quiet replacing with nomodeset - but not change.

running Linux Mint 21 "Vanessa" Cinnamon Edition in the meantime, which is strange given both Zorin and Mint are both Linux distributions based on Ubuntu --- something for the Zorin gurus to resolve, way beyond my :cowboy_hat_face: knowledge :frowning:

I know, it is kind of odd. Hopefully, the links I posted above can give the developers a hint as to what they need to change.

1 Like

What kernel is it using?

Kernel 5.15 and an Ubuntu 22.04 package base