Zorin 16.3 boots into tty1 not desktop

Hello i was installing wine and accidentally installed the wrong one focal and lunar versions so I tried uninstalling through a variety of ways and found myself uninstalling critical packages and dependencies. I mistakingly used sudo apt autoremove and it removed alot of packages then i restarted my pc and now the desktop is gone and I can only boot into the empty black screen tty1 screen asking for my username and password. I was able to login and tried to install gnome again but it says

sudo apt install --reinstall gdm3

the following have unmet dependencies
gdm3: gome-session
E: Unable to correct problems, you have held broken packages

You can try sudo apt install zorin-core-desktop. This should bring in all of the dependencies and the basic core desktop (if you're on core.

1 Like

Hello this is the output i recived:


sudo apt install zorin-os-desktop

1 Like

My mistake... sorry about that.

same message error message as previous

You might need to check your sources.list

How do you feel about backing up all personal files and reinstalling the OS?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.