Zorin 16.3 Core, System Tray icons no longer appear for running applications

After using this newly installed Zorin 16.3 Core System, it seems that when I set applications to autostart (via an ~/.config/autostart entry), the icons no longer appear in the System Tray


even though they can be seen in the System Monitor.

I have found many other similar posts here that either seem old or not appropriate for my situation (such as removal of the appindicator-*, sudo apt install libappindicator-dev, restarting login session, etc).

Frustratingly, I have to ask why topics are auto closed 3 months after the last post? This seems to not be appropriate at all for tech related topics where problems may reappear, etc (for instance, is it an underlying Gnome issue?).

Anyway, I have also observed in one instance, where I kill a running process such as Flameshot, then restart it, its icon reappears in the system tray.


Interestingly though, the syncthing-gtk icon always seems to consistently remain in the system tray (different system than the one shown in the screenshots -- thus no Syncthing icon).

I have observed this same behaviour on two different Zorin OS 16.3 Systems.

The applications whose icons are not showing were not installed via snaps, flatpaks, or the like.

My system:

Topology: Dual Core model: Intel Celeron 4205U bits: 64 type: MCP 
  L2 cache: 2048 KiB 
  Speed: 800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 800 2: 800 
  Flags: 3dnowprefetch abm acpi aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  flexpriority flush_l1d fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp 
  hwp_notify ibpb ibrs ibrs_enhanced intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  ID-1: / size: 456.88 GiB used: 16.12 GiB (3.5%) fs: ext4


        `osssssssssssssssssssso`           user1@user1-inspiron 
       .osssssssssssssssssssssso.          -------------------- 
      .+oooooooooooooooooooooooo+.         OS: Zorin OS 16.3 x86_64 
                                           Host: Inspiron 3580 
                                           Kernel: 5.15.0-82-generic 
  `::::::::::::::::::::::.         .:`     Uptime: 1 hour, 17 mins 
 `+ssssssssssssssssss+:.`     `.:+ssso`    Packages: 2127 (dpkg), 12 (flatpak) 
.ossssssssssssssso/.       `-+ossssssso.   Shell: bash 5.0.17 
ssssssssssssso/-`      `-/osssssssssssss   Resolution: 1366x768, 1920x1080, 1440x900 
.ossssssso/-`      .-/ossssssssssssssso.   DE: GNOME 
 `+sss+:.      `.:+ssssssssssssssssss+`    WM: Mutter 
  `:.         .::::::::::::::::::::::`     WM Theme: ZorinBlue-Dark 
                                           Theme: ZorinBlue-Dark [GTK2/3] 
                                           Icons: ZorinBlue-Dark [GTK2/3] 
      .+oooooooooooooooooooooooo+.         Terminal: gnome-terminal 
       -osssssssssssssssssssssso-          CPU: Intel Celeron 4205U (2) @ 1.800GHz 
        `osssssssssssssssssssso`           GPU: Intel Device 3ea1 
                                           Memory: 5178MiB / 7798MiB 

Installed packages:

Textual Listing of Installed Packages (link via dropbox)

1 Like

Because new posts might end up added to already solved threads; new posts might be added to threads that are not actually related to that users issue and so on.
Keeping individual issues separate helps reduce confusion.


You are not the first user to note apps not showing up in the tray since 16.3. So this may be a pervasive issue with App Indicator Extension.


Just to check, see if you hid the icons box from the taskbar, so right-click the taskbar > Taskbar Settings > Position > Right box must be set to Visible. On Windows all those software icons are in the system tray, on Zorin OS they are in this separate box.


Hi Luca, Thank you for your response. Yes, the Right Box is set to Visible:

So long as I disable the autostart of the two applications which were consistently disappearing (CopyQ and FlameShot) and simply started them when the desktop loads, the icons for these show in Zorin OS's System Tray.


1 Like

Disabling software autostart shouldn't mean that they won't appear on the right box once opened. I was thinking that you blocked the service that makes the 2 software display their own icon on the right box instead of the software themselves.

When I installed and ran Flameshot I noticed the icon on right side of panel.
Not liking that, I think I found a setting in the app itself to turn that icon off.
I instead have Flameshot as favorite, with icon on left side of panel with the other app launchers.

Success!! Thanks so much for your time and assistance @337Harvey! That was indeed the issue.

So, in /.config/autostart, I added something like the following to the end of both the CopyQ and Flameshot desktop entries (the problematic applications):


Thanks again!! Cheers.

1 Like

:wink: This system is a 2-Core Celeron processor from 5 years ago with 8 Gigs of RAM (and this using a fast NVMe drive).. so, yeah, I consider it slow. I should probably have put Zorin OS Lite on it. Anyway, I timed it. The duration is about 14-15 seconds from the time I hit the Enter key after having typed in my login password to getting to a fully loaded desktop screen. So I might change the delay to 17 or 18 seconds.

Thanks again!

1 Like

Hi, I had issues with CopyQ after installing it from the software store. As mentioned above, it worked great a few weeks until the icon dissapeared from the tray. I realized that it was not in the System Startup, which I did.

Then, I added the X-GNOME-Autostart-Delay=15 in the newly created /.config/autostart/copyq.desktop.

it is working for now. I hope that it holds water. Without the tray access, the program is useless.

On another note, I installed Flameshot and Shutter. Flameshot stopped working, tray issues I guess. Shutter is working for me now. Not perfect, but does the job.

I hope this helps someone.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.