Zorin 16.3 Education Lite in Dual Boot with Windows 10 wont load grub menu on m72e lenovo

Ive done this multiple times on other computers using a previous version of zorin (the one before 16.3 education lite) and I had no issues getting a boot menu to choose between zorin and windows but somehow Ive run into issues with these 2 lenovo thinkceneter m72e

my procedure:

I have a 120GB that split in half, and choose the first partition to install windows 10, the install runs smoothly
then I go into bios disable fast boot and choose legacy mode as opposed to uefi,
then I start off my zorin usb installer, run the install with manual partition, I do 30GB for root, 6GB for swap (4gb of physical ram on the pc) and the rest is for home. the installation runs smootly,

when is time to boot of the ssd drive i get no operating system

Things I tried:

  • if I change the boot mode to uefi, I get windows 10 booting (no grub/windows boot menu)
  • I have wiped the zorin partitions and Ive tried to install with boot mode uefi but same thing
  • I have tried to do a several boot repairs, some worked yet did not resolve my issue but some in some I get an error: this is the last pastebin url generated: http://sprunge.us/BclHhZ
  • I have removed and put back the cmos battery as it was one of the solutions suggested when getting an error related when getting Locked-NVram detected when attempting to do a boot repair, yet after doing that and running a normal boot repair the issue continue exactly the same.

as I said, Ive done this several times with the previous os version and I had no issues... this is the first time on these machines though and the fist time trying to do an install with 16.3 zorin os.. so I was hoping to get some help as Im clueless what i need to change to get zorin and windows working off these lenovos TC m72e

To address the NVRAM is locked message, you can try clearing the CMOS battery and Jumpers.

I tried the battery, will check on how to do the jumpers.. thank you.. will report back.

1 Like

Just tried clearing cmos with jumper, I got 2 beeps after setting the jumper in the clear position, turn off and put the jumper back in the original position, turn the pc on again and went back into bios, setup defaults, and restart, then attempted to do a boot repair from live zorin and and then same thing happened: boot repair fails saying nvram locked detected.
I got 3 of these machines thinking that it was going to be a breeze getting dual boot on them like it has on others... did I make the wrong call on this hardware?

Secure Boot in BIOS - Enabled or disabled?
Fast Boot disabled?

Thought not quite specific to your Model, please read this post here:

I started over
installed windows, all good
disabled fast boot within windows and also in the bios
there's no secure boot option in my bios so I guess that's off
installed zorin 16.3 all good, this time I used the option to install zorin along windows boot manager, the install went fine, restarted and then... Windows is the only thing booting up, no grub menu options.

I tried again to do the boot repair from live zorin, but then again it fails with a new paste bin (or maybe the same) you tell me: http://sprunge.us/Z3I65z

I emailed boot.repair@gmail.com as suggested by boot repair, not sure if that's going to go anywhere but I send them off the paste bin report

I did read through your link you provided which is still a problem as per my last attempt to do a boot repair as the error still says nvram locked detected, but I couldn't find anything that I could do to fix the issue and that I haven't done. I even looked to see if it was possible to update the bios but I get errors also when trying to do that and there are reports of systems getting bricked after trying to do the bios udpate so I'm not sure if I want to push for that option. I saw some lines of code and I read through it but I'm not sure if that's something I can implement. (sorry I'm noob and a wanna be system admin)

I'm wondering.. shouldn't sda5 be the one flagged with boot assuming that's where grub is supposed to be installed?.. I think I tried fix manually in gparted but that got me a no os error... what If I were to add linux to a windows boot manager is that something I can do? if so.. any idea how?

Thank you.

For EFI boot; Grub will install on the EFI partition.

For MBR, it will install a file for the Legacy bootloader.

good to know, not that it helps my case but thank you

Did you create a /boot partition?

no, no boot partion.. only /, /home and swap

Well try again, this time create a boot partition 1st then root, swap and home. hope it fix the issue

ok.. i think I figured it out

I gave up on zorin and decided to try out mint, as it I had no issues in a similar machine before I found out about zorin, unfortunately the problem continued, the mint installed went ok but after first reboot, I got windows

I decided to try to boot repair again from the mint live usb boot, so I reboot into the live mint os, loaded boot repair and let it do it's thing.. to my surprise it did completed something with no nvram locked error detected, I got this instead:

so with that message ready, I proceed to restart, it went straight into windows (no boot menu still).. but I proceed to add the entry in boot manager as indicated by the message: i went into windows, open cmd in admin mode and enter the command:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

the message executed without any issue and then it was time to test it out, I restarted and lo and behold... the freaking boot menu was there, with linux at the top and windows option 2 entries below.

With that addition already in windows boot manager, I wiped mint and proceeded to try to reinstall zorin (I do like it a lot and most of the machines at the school already have it so I'm kind of married to it by now), this time, during the install, I also selected explicitly the windows boot manager partition as the device for bootloader installation (I've never had to do that but after watching a video on dual boot setup it suggested to do so), the installation run ok and when it was time to restart... the boot manager with zorin, advance zorin options and windows (3 entries) were there ready for me to choose what to boot (zorin being at the top being the default option)

not sure if it was the bcdedit command to add the linux entry to the windows boot manager or the explicit usage of the windows boot mananger as the devices for boot loader installation, but one of those (or both) did the trick and now I can continue with my life for a change.

Hope this helps some one and thank you guys for getting back to me, keep up the good work and see you on the next cluster-f.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.