Zorin 16 beta fails to load with UEFI

I am a satisfied Zorin 15 user and eager to try Zorin 16. Today I downloaded the beta ISO and created a bootable USB. When I tried to boot up Zorin 16, after choosing Try Zorin..., I got the following:

error: out of memory.
Press any key to continue...

I tried recreating the USB and encountered the same error. Then I tried booting it up with as a legacy usb (not UEFI), and it worked. I am hesitant to install using the legacy usb route because of past experience. Recently I made the mistake of reinstalling Zorin 15 using legacy usb, and Grub was not visible to the bootloader, only Windows. I would welcome input if I am missing something.

Just to fill out details, I am using a Dell XPS 13, dual booting with Windows 10.

Out of curiosity, and it sounds like you have some idea of what you're doing, did you ensure fast boot, secure boot and windows fast boot options are all disabled? Is your bios up to date? Gnome DE can use a lot of memory to get started (up to 2+ GB, but you're laptop should be able to handle that according to the specs).

At boot you could run a memtest, in windows you could check the resource monitor for memory issues and temps. They could be overheating and failing due to this or one of the modules may be bad. Testing individually and together would help you narrow it down. The last possibility is that the motherboard is beginning to fail. If you eliminate temperature and ram module failure that is the last possibility i can think of.

Do you experience any issues in windows?

EDIT
Which way is windows installed (if uefi there will be an efi partition listed in disk management). In order to dual boot, both OS's must be installed in the same manner (legacy or uefi). Attempting to have both can cause many issues.

1 Like

To add: You can run grub repair if needed when installing in Legacy to solve that issue.

Booting to UEFI requires there to be an EFI partition present that allows the installation medium to set the starting point. If not present, it cannot proceed - you can create one, however. So, there are two options for you: Legacy with grub repair if needed, or create the 256megabyte EFI partition, then install normally.
Both should work, but I would suggest that installing your dual boot Linux OS in the same mode that Windows is installed is the safest practice.
It sounds like your Windows Installation is MBR BIOS, so your Linux OS should be as well- That is legacy.

1 Like

Thanks, @337harvey . I updated bios and made sure secure boot was disabled. I could not find any settings for fast boot. I originally installed Windows and Zorin 15 using UEFI, so there is an EFI partition. I tried to run memtest86+, but I could not find a way to get it to show up in grub. While running Zorin 15, free -h shows 11G of memory free, if that helps. There should be plenty of memory. But now when I boot using UEFI and choose one of the Try Zorin... options, it just goes to a blank screen, no message about memory.

@Aravisian given that the Windows bootloader shows up under UEFI boot options, I am pretty sure it was installed using UEFI.

Fast Boot settings are found from within your Windows Operating system, not in the BIOS settings. I am not exactly sure where... But you can probably run a google search to find out or explore your Control Panel.

That is very odd. It seems as if your EFI partition is not being seen.
I just did a search to see if I could find any similar situations.

Thanks, @Aravisian , I found the fast boot setting and disabled it. But still no success. I decided to go ahead and install alongside Zorin 15 using legacy, but of course the install is not visible to grub yet. I will see about fixing that and see what happens.

When I read the link you shared regarding the memory issue for Ubuntu 17.10, the main solution was to create a swap file. But it seems the problem was running out of memory while the system was already running, rather than a Live CD/DVD/USB.

I agree and it does seem to be an odd error to encounter during installation.
Have you done a memory test and a disk check?

I was unable to get memtest86+ to appear in grub. I did start looking for badblocks, but I lost patience and just installed using the legacy method and then repaired grub. So I am writing this from Zorin 16. Thanks for trying to help. When the stable edition comes out, I will try it again.