Zorin 16 blank screen on boot (Intel UHD 620)

Agreed. But Secure Boot can cause applications to fail, it should not cause a Black Screen on boot.

All right, so I installed OEM kernel 5.10, tried to boot with that kernel, the issue still persist.

However, I discovered, when I boot to Recovery and 'resume' then the system boots without any issues. I successfully tried on all 3 kernels: 5.10, 5.11 and 5.13.

This looks like some conflict/issue with that graphical "Zorin" screen. When I skip graphics boot screen and only boot text sequence is displayed, the system boots just fine.

You might try reinstalling GDM3... Though I notice that some other users, (not very many) have had some issues with Plymouth, recently...
I wonder if it is the Plymouth package.

One more catch - when I hit ESC during boot, to see boot text sequence, it does not work - it boots up to login page, but after a 2-3 seconds I get black screen and the system freeze.

The system I have is fresh install from v16 and v16.1 images downloaded today.

I will try to reinstall GDM3 and let you know if that helped...

if the GPU drivers are unable to be loaded, and plymouth is rendered by software, then I can only assume that Intel's GPU drivers didn't load

It is definitely worth it for the O.P. to double check secure boot.

I reinstalled GDM3 using 'sudo apt reinstall GDM3', but without any success. The issue persist. The system boots, Zorin logo blinks, "Zorin" text displays and that's it...

You may have late start KMS... There are a few things we can try. First, from the Recovery Menu, drop to prompt, then let's try

sudo nano /etc/default/grub

Find the line for "quiet splash" and add video=SVIDEO-1:d so that it looks like:
"quiet splash video=SVIDEO-1:d"
Then test.
You also may try just setting it to
"video=SVIDEO-1:d" without the quiet and splash which will be verbose and not show the Plymouth splash screen, just to rule out Plymouth.

If the above does not work, you may need to add intel_agp before i915 to suppress the ACPI errors, which will need a guide for...

P.S.: Don't forget to run sudo update-grub :stuck_out_tongue: (I often do...)

I tried "quiet splash video=SVIDEO-1:d" - issue persist.
I tried "video=SVIDEO-1:d" without "quiet splash" - it boots up to user login page, but the system freeze when I click on the user (to log in). If I do not click on anything on login page, I've got black screen after about 15 seconds and the system froze.

The only way how to boot normally is to use "nomodeset". But even though when system goes to sleep, it will wake up with black screen and I have to hard shut down.

I am sorry to ask the obvious... But does sudo apt update show any missing firmware?

Have you tried booting under legacy and seeing if that fixes the issue or still the same?

I updated the system, it's running latest firmware, incl. latest BIOS version.

Yes. No difference, same issue.

It's odd because the issue your facing doesn't quite add up to the problem. As between myself and Aravisian it looks like the usual fixes aren't working.

I suggest downloading a new ISO and doing a fresh install as it seems like it may be a bad ISO download if all your firmwares are up to date

It's not the first time I have seen nomodeset work on a single integrated chip; it's just unusual. While the general sense is that it uses integrated as the fallback, that may not be the fuller picture.
If the Intel integrated chip is using modesetting driver, then some odd things may happen.

@justinc 's advice of a fresh reinstall may be the first things to try; It often works.
Otherwise, it may be that switching away from the modesetting driver may show some interesting changes.

I thought the same and downloaded ISO again and fresh installed v16.1. The issue persist.
I took further step... as Zorin is based on Ubuntu, I downloaded latest Ubuntu 20.04 ISO and fresh installed. Result is the same issue.
Interestingly, Fedora Linux 35 won't boot either, unless I update grub with 'nomodeset'. I do not know to what extent these Linux distros sharing graphics drivers?

I'll try what @Aravisian refered and let you guys know.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.