Zorin 16 Core needs to be unlocked more than once

Hi, I am having exact same issue. The only difference is I see the wallpaper in both lock screens.

I am running Zorin OS 16 Core.

Can anyone please help me? I don't wanna reinstall this.

Is your situation the same as the above O.P.- that is you experience this from Hibernate? Or from any lock?

From lock screen. I haven't tried Hibernate.

I wonder if you are seeing the lockscreen and the screensaver.
Can you try disabling the screensaver with

/usr/bin/gnome-screensaver-command -d

And test after a Full Reboot?

Sorry, for the late reply. I ran the command and it says that no such file or directory.
2022_01_29_0jj_Kleki

Another thing, this issue occurs very randomly.

Interesting...
Can you check your installed packages and see which screensaver you have installed?

With my very little knowledge with terminal and Ubuntu itself, when I ran
apt list --installed, it printed all the packages installed, but none of them has screensaver word in it.

To be sure, I ran again below command:
2022_01_30_0ni_Kleki

So, I guess I don't have any screensaver package installed.

Well... let's try installing it and setting it up and see what difference it makes...

sudo apt install gnome-screensaver

Hi, I am testing this for a week now. The issue persists.

Have you checked if you are logging into Wayland?

How to do that? I am a complete newbie to ubuntu. You have to guide me here.

From your Log In Screen, you can select whether to log in on the current desktop or a different desktop (if you install one, which I suspect you have not).
You can also select whether to log in on the current X Window server or on Wayland.
You can do some searching about Wayland to learn all the details - I will tell you it is a great idea that stalled out for a decade and has really made little in the way of progress. Many apps do not work on Wayland.

Click the gear icon for your user to see these options.

I see. No, I am not logging into Wayland.

1 Like

Can any Zorin OS Core users confirm whether gnome-screensaver is missing in their build? It is present in mine...

Installed Zorin OS Core last night and i can confirm gnome-screensaver is missing.

1 Like

I must have installed it in a flurry of activity at something.