Zorin 16 Lite Software Centre Error

Keep having to repair Gnome Software centre as an error pops up The name:3.77 was not provided by any service files. Is there a permanent fix for this as it has happened about 3 times in as many weeks.

Would you paste the error here? I realize you attempted to include a much detail as possible, but there may be more you have forgotten or didn't include as you thought about it.

Have you checked your sources in the software updater? Disable anything that mentions focal, if you are on Zorin 17.

Having both sets of repositories enabled can cause conflicts and result in what you describe.

Moved to General help as you are requesting assistance and not providing feedback.

image

Just opened it today and got the error again. No 17 components installed.

Are you on Zorin 17?

Did you upgrade or fresh install?

Zorin 16 Lite fresh install as per title.

Forgive me, it's been a long couple of days.

Did you verify the hash prior to installation?

If it doesn't match what is posted on the Zorin website, you may have to download and reinstall.

What does sudo apt update in the terminal output?

In software update app, what server is your system configured to use?

It sounds like missing dependencies.

Verified the hash.

sudo apt update - all packages are up to date.

Software update is set to Main server.

It seems to happen most when I refresh the update tab.

image

Now getting the above.
image

This may be server congestion... but not an error that is seen a lot.

You can try sudo apt clean (in terminal), to clear caches and hopefully prevent the error from occurring again.

You could try the following:

First make sudo apt update && sudo apt upgrade. Then open Gnome Software and let it open. Then open the System Monitor and look in the Process List for gnome-software. Click on it and end the Process. You will see that the Gnome Software Window disappears. After that open Gnome Software again and look if it works.

Fixed for now @Ponce-De-Leon I will update this thread if it happens again.

1 Like

image

Happened again. Opening software then terminating in task manager and opening again fixes. Strange.

Changed Update server to UKFast using the server test but it still happens.

Hmm ... Did You tried a sudo apt reinstall?

1 Like

I did but just terminating the program also has the same effect. I searched for a solution and it was to reinstall but it comes back.

1 Like

Maybe it is a Bug ...

1 Like

Seems so is why I put it in feedback.

Maybe untick the post marked as "Solution" as problem reappeared.
If you prefer this thread to be in "Feedback", rather than seeking Help, please say and I will move it there. The alternative would be to keep here but flag to "staff". Zab

Without knowing for sure what you have tried...

sudo rm -rf /var/lib/apt/lists/*

sudo apt clean && sudo apt autoremove

sudo apt update && sudo apt upgrade

sudo apt install --reinstall update-manager gnome-software fwupdmgr

Reboot...

E: Unable to locate package fwupdmgr

@Aravisian seems to have fixed it for now. 4 refreshes of the software manager updates (usually when it occurs) and no errors.

Will update this thread but cautiously optimistic.

You can run

sudo apt install --reinstall update-manager gnome-software

Odd that fwupdmgr is not present...
https://manpages.ubuntu.com/manpages/focal/man1/fwupdmgr.1.html