Zorin 16 Lite Software Centre Error

You could try the following:

First make sudo apt update && sudo apt upgrade. Then open Gnome Software and let it open. Then open the System Monitor and look in the Process List for gnome-software. Click on it and end the Process. You will see that the Gnome Software Window disappears. After that open Gnome Software again and look if it works.

Fixed for now @Ponce-De-Leon I will update this thread if it happens again.

1 Like


Happened again. Opening software then terminating in task manager and opening again fixes. Strange.

Changed Update server to UKFast using the server test but it still happens.

Hmm ... Did You tried a sudo apt reinstall?

1 Like

I did but just terminating the program also has the same effect. I searched for a solution and it was to reinstall but it comes back.

1 Like

Maybe it is a Bug ...

1 Like

Seems so is why I put it in feedback.

Maybe untick the post marked as "Solution" as problem reappeared.
If you prefer this thread to be in "Feedback", rather than seeking Help, please say and I will move it there. The alternative would be to keep here but flag to "staff". Zab

Without knowing for sure what you have tried...

sudo rm -rf /var/lib/apt/lists/*

sudo apt clean && sudo apt autoremove

sudo apt update && sudo apt upgrade

sudo apt install --reinstall update-manager gnome-software fwupdmgr


E: Unable to locate package fwupdmgr

@Aravisian seems to have fixed it for now. 4 refreshes of the software manager updates (usually when it occurs) and no errors.

Will update this thread but cautiously optimistic.

You can run

sudo apt install --reinstall update-manager gnome-software

Odd that fwupdmgr is not present...


After 6 hours uptime. @staff

Were any related system log entries posted?

Maybe leftover configuration files? Perhaps purge might be called for, alongside reinstall...?

Just my two cents:

For some reason, to me... This seems like something you might see if you maybe try to install a corrupted or b0rked .deb file or something with some script that was set to run upon login and called by your .bashrc (persistence through boots), Install Linux Application or Run Software.

As in... it keeps checking some script for things to look for to install or update based on data that it wasn't told is no longer available on the machine... but since the application is not installed, there is no .service file to associate with whichever application's version numbers keep showing up in your gnome-software-center.

I want to now ask if it's possible that something like this happened with a start-up application script or something similar...?


Check for remnants of faulty startup script or configuration, or old, downloaded .deb or Linux executable files?

Reset or purge Gnome Software Center and all it's settings and reinstall?

Look for dependency issues. Any messages? Try Synaptic to view which applicationsare installed, by source, and then filter out any applications that appear to you to match the string found in the error you're seeing in the gnime-sofware-center?

Can you try (it can take some time to run):

sudo dpkg --verify

sudo dpkg --configure -a

Reboot and test...

First run no error. Will test after 6 hours uptime as that's when the error seems to happen. Terminating or rebooting fixes.

1 Like

After 5 hours the error pops up again. What's missing from when I start Software Centre is the check of downloading software from servers that is present after a reboot.

This is a persistent issue.

We tried clearing your apt cache using two different methods above.
And tried reinstalling certain related software packages.
Have you checked your sources?
Do you have any snap packages installed?

snap list

And updated all Snaps:

sudo snap refresh

Flatpak packages?

flatpak list

and updated any flatpaks?

flatpak update

I have noticed when installing software sometimes the error pops up sometimes not, pretty random.

All snaps up to date.

flatpak update
Looking for updates…

Nothing to do.


All the sources under Other Software point to focal.

Software Centre seems to function normally installing/removing software just an annoyance.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.