Zorin 16 Multiple Monitor, works in Live session, but black after install

I have a AMD 5600 video card and 3 monitors. I purposely used Zorin in "Try" mode from a USB drive and confirmed that everything worked as intended.

After installing, monitor 1 is blank. It shows up in the "Display Settings" but is turned off. I turn it on, and press apply. All monitors go blank for a moment then... nothing. Same as boot. Only monitors 2 and 3 work.

Where do I need to look to start troubleshooting this?

From the app menu, can you open Software & Updates. Ensure that the checkbox for Software restricted by copyright or legal issues (Proprietary) is set to ON.
Then go to the Last tab Additional Drivers. It will Search for drivers based your hardware.

What does this yield? Any AMD drivers you can install or enable? That it worked in the Trial is Good News- we know it works. :wink: Now we just need to figure out which drivers it was using.

Shows "No Drivers Found".

Can you open a terminal with ctrl+alt+t and copy this and paste it in, then hit enter:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Then this

sudo apt update && sudo apt full-upgrade

Then please reboot and test monitors

2 Likes

That WORKED! Thank you so much!

2 Likes

Who says third try is the charm?

I do it in TWO.

1 Like