Zorin 16 Multitouch gesture

Hey there! I used Zorin 15 a while ago and no came back to 16 again but a am still some kind of beginner . While everything works fine out of the box, the touchpad gesture with three finger pinch/tap (i read both on some sides) doesnt work. the 4 finger swipe to switch workspaces works fine, 2finger scroll works fine too. only three finger pinch/tap doesnt work.my laptop is a hp omen 15 with a synaptics touchpad. when i tried libinput on mint it worked fine with three fingers.
hope someone could help me out with it. regards
Simon

1 Like

Have you tried it on Zorin OS? Repalce $USER with your actual username below:

sudo gpasswd -a $USER input && sudo apt install wmctrl xdotool libinput-tools

Install the following driver:

git clone https://github.com/bulletmark/libinput-gestures.git

cd libinput-gestures

sudo ./libinput-gestures-setup install

libinput-gestures-setup autostart start

Configure:

sudo nano /etc/libinput-gestures.conf

thanks for the reply. i didnt try libinputgestures on zorin. i hope that there is a workaround to make it work natively since the touchpad works fine except for that 3 finger pinch. i read that touche is already installed in zorin 16 so i wont cause any conflicts.
mayby that 3 fingerpinch isnt supported by my touchpad at all so mayby it only works with a 3finger tap. this would be nice if there is a possibility to change that.
regards

1 Like

That is good thinking. I do not use touchpad or gestures.

Most of the gestures I make toward my computer cannot be used in polite company.

Maybe some other users that use touche and touchegg can comment in better detail toward your question.

1 Like

so i installed touche via the appstore and configuered a three finger swipe for the activity overview. looking at the settings in touche 4 finger swipe is occupied by gnome for switching workspaces and cant be disabeld, threefinger pinch was activated but with no function on my laptop. but its a fine and easy solution for me. hopefully this will help other zorin users too :slight_smile: