Zorin 16 only can only access local network

Hi,

I recently installed Zorin OS 16 (after a while on 15.3), and it worked flawlessly for a day or so, until this morning it won't connect to internet.

  • WiFi works fine
  • i can ping my router using its IP address (and access its web interface)
  • i can ping a NAS on the LAN using its name (and access its web interface)
  • i CANNOT ping any website (nor access it obviously)
  • Connection by ethernet cable makes no difference
  • I have not -knowingly- tampered anything with regards to firewall, iptables or anything else network related
  • I do however have installed ProtonVPN and ProtonMail Bridge (and i don't mean to point fingers as those have never been an issue in the past several years)

Any help much appreciated, if that can save a re-install bound to lead to the same issue.

Thanks !

In an attempt to understand a little better i must ask a few questions that will be obvious to you, please forgive me and be as detailed as possible.

Do other devices have issue connecting to the web as well?

Is your VPN setup on Zorin alone or on the router?

If it is on Zorin alone, did you go through settings and turn off the option to block all network connections unless in the VPN? I don't use those VPN providers, but in Nord there is an option to do just that. You may have to disable it in both applications to access the web without the VPN on. I do not know how to change that option in those applications.

When you install a VPN you inadvertently adjust firewall settings, because that is how VPNs work...fyi.

2 Likes

Thank you for your message, all other devices on the network connect just fine, including my laptop when booted on Windows (double boot). So this isn't a hardware issue either.
The VPN is setup on the laptop, not on the router.
I have now uninstalled hte VPN, and checked that the firewall was switched off, yet still no joy, in can't ping anything further than the local network.

Thanks,

What is the output of

sudo lshw -c network

Thanks for your help, in the end, i went nuclear and re-installed Zorin. All works as expected including VPN (now using openvpn rather than the dedicated Proton client).
I will follow up here if the fresh install is faced with the same issue again.

2 Likes