Zorin 16 Pro on the Frame Work laptop

Wanted to share for those who might be interested of my trials, tribulations, and successes as I progress down this road.

I received my Frame work (frame.work) laptop on Friday 11/12/21. Was wiring my garage and that took two day priority over my itch to get it up and running. After watching a youtube installation comparison of 6 distros (Best Linux for Framework? 6 Distros Tested! - YouTube) I decided to try Fedora, as it was the only one that was not going to take custom scripts to get critical services to function. The reason I did not instantly go with Zorin was due to it getting the lowest hardware compatibility rating of the six. I did install Fedora and it worked as stated, but the GUI is not my cup of tea. So today I paid for and downloaded 16 Pro, after previously paying for 15. An Etcher install later and ripping the ISO to the USB stick, I started installing Zorin.

All went well, until I restarted the laptop and it asked to run Zorin Connect and upgrades. Nothing worked, and for a couple seconds I was confused, largely because I forgot that the 6E AX210 WiFi vPro radio does not work out of the box.
If I were new to Linux, which I'm not, I would throw my hands up and ask WTF. While I'm not excited to have to script in a functional driver, I understand that in dog years Frame Work is a relatively new hardware offering, and sometimes the Linux development for drivers lags a bit. This is one of the reasons that Linux is not generally or more widely accepted among the average computer user. Apple exists for those people, and the longer Windows is around, they too have given more focus to newer users having to install the OS themselves.

Since I'm not able to access the internet from the laptop to get updates, I'm on my Zorin desktop to find a solution and provide incremental updates to the community.

On a very positive note, Zorin does come up properly on the Frame Work, with a fairly large icon and text display, but that can be changed in settings.

I'll follow up once I get the drivers for the radio fixed. If anyone else has encountered the same issue with the wifi card, and even better, has a link to functional drivers, that would be a great help and cut my Where's Waldo driver hunt. I really don't want to have to drop a dual boot Windows 10 version on there so that I can get Zorin working. Not going to bash (pun) to hard on Windows, because I lived in that world professionally for almost 30 years. Zorin does not want to, nor should it have to use Windows as a crutch to get the most basic wifi functionality.

My Frame Work config is as follows:
Intel i7 1185G7
The 6E AX210 wifi card
Two 32Gb Patriot modules (purchased from Amazon for $107 each)
One Samsung 970 Plus 1 Tb M2 card

I do not own the same system and I cannot help you but I hope other embmbers members pitch in to help you.

As your husband may say "the right notes, but not necessarily in the right order" (typo :wink:)

I don't know if that BBC link will work outside UK though.

2 Likes

Crosslink RE: Wifi drivers:

There appear to be three separate threads on this...

1 Like

Shall I consolidate them to concentrate our work?

[edit]
I merged the other thread here.

[edit 2]
@Bluepig
It is highly appreciated if you could create only one thread per issue.
There are less than 4 active moderators on this forum and spreading our attension to more than one thread is counter-productive.

I'm running the new Frame Work laptop, and am currently at day one install of 16 Pro, and at a hard stop with the absence of wifi (working from my desktop).

Might this help?

(You need a temporary internet access to download drivers.)

I'll head that way and see what I can find. I'm working from my Zorin desktop, so I have access to the world.

1 Like

Yes.

Ensure the sources go in /usr/src/

You must also install backport-iwlwifi-dkms.

Grab the Firmware that is needed:
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

Ensure that these go into /lib/firmware/

Normally, I would have done the above as a series of Terminal Commands, but it seems you will be doing this one over USB transfer.

1 Like

(Deviation alert)
Aoccdrnig to a rscheearch at Cmabrigde Uinervtisy, it deosn’t mttaer in waht oredr the ltteers in a wrod are, the olny iprmoetnt tihng is taht the frist and lsat ltteer be at the rghit pclae. The rset can be a toatl mses and you can sitll raed it wouthit porbelm. Tihs is bcuseae the huamn mnid deos not raed ervey lteter by istlef, but the wrod as a wlohe.

2 Likes

With Framework notebooks, they require the 5.12 or newer Linux kernel for all hardware to be fully supported. Since Zorin OS currently uses 5.11.38, that might be where the issue lies in hardware support.

I haven't booted up my Zorin machine in a long time, so I can't say for certain if a new kernel got released. But last I was on my Zorin machine, it still was using 5.11.38. But of course, I remember having locks put on the 5.13 kernel.

Is there anybody who can provide their most recent Zorin screenfetch or Neofetch in their terminal please? Just trying to figure out what the latest kernel that Zorin is officially supporting at this time for Zorin users who don't have locks on their kernels.

But yes, Framework at the end of the day, recommends kerne 5.12 or newer, I discovered this by doing a simple google search.

That is correct, cause I understood every word of that. :crazy_face:


1 Like

Zorin uses 5.11.40 kernel these days. For that machine i would use pop

1 Like

Thank you Michel!

Results just in...

The kernel is still too old. Framework requires 5.12 and up. So, gonna have to wait a bit longer for full FrameWork support.

But knowing Michel as I do, he knows how to manually install a newer kernel, don't you Michel? HEHE


2 Likes

Yes i do :sunglasses:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.