Zorin 16 Software Problem

Cannot get the Software center to load therefore I cannot get software to install on my computer but the software updater works in manual mode. Does this work on the Beta version?

Yes, it should be working just fine. Can you detail your experience, what you are seeing, etc.?
If you launch it from terminal

gnome-software

does it show any errors?

The app opens via icon or terminal but nothing is displayed. All icons are gone and only three dots are displayed everywhere there should be an icon. . .

Can you run the following commands in terminal:

sudo apt update

sudo apt dist-upgrade

Then reboot and test the Software Channel?

Aravisian - now all it does is sit on this screen.

:disappointed:

Bleh... I never use the thing... I use Synaptic Package Manager if I use a Package Manager at all...

Ok, let's try:

sudo apt install --reinstall gnome-software

sudo apt install --reinstall zorin-os-desktop

sudo apt-get install -f

sudo dpkg --configure -a

If no errors, reboot and test. If errors, please report them in this thread.

Done with

zero progress - here's my screen now. Oh, no errors . . .

Can you open Software & Updates from your app menu.
Check on the first Tab that Download From is set to Main Server.

I guess since this OS is beta I will load Synaptic Package Manager and use it for now . . . no problems. After we get a stable release of 16 I will reload the drive.

It is set to Main Server.

Ok, let's try one more thing. I understand if you are frustrated.
Let's clear out the cache

killall gnome-software

rm -rf ~/.cache/gnome-software

For flatpack run

flatpak --user update

Then again:

killall gnome-software

Log out and in or reboot and test...

No dice . . .

I am at a loss. I tried a google search and saw that a lot of people complain of the same issue. I saw a lot of the same "fixes' we just tried. And quite a few people saying that it magically started working again- usually after an update.

If everything else is working fine; perhaps installing Synaptic and waiting on an update will do the job.

sudo apt install synaptic

In the meantime, I will tag this thread for the ZorinGroup @azorin and @zorink to see; Unresolved Gnome-software issue: Incessantly loading.

1 Like

Thanks for the good assistance Aravisian!

1 Like