Zorin 17.1 core NVram locked issue when Zorin 16 core install perfectly

Hello all,
I encounter a really weird problem on a PC TAB 1001-2. This is a pc/tablet hybrid with very poor specifications :

  • AtomTM Z835 processor X64 based
  • 4 Go DDR
  • 32 Go of flash memory integrated

I had Windows 10 on it but when i have reinstalled Windows on it, nothing worked (sound, touchscreen, Wi-Fi and Bluetooth) and i have tried Zorin 17.1 Core on this device. It boots and runs great on live USB key but when i try to install it shows an error: Execution of "grub-install /dev/mmcbik1" has failed.
I have read some topics about this error and they suggest me to live boot on Zorin 17.1 and try to repair the boot with the boot repair tool what i have done but this tool shows me an error too "Locked NVram detected". This device is disabled on secure boot and this is the only option available in the BIOS.
I don't know how to have Zorin 17.1 Core on this device when with Zorin 16 Core i have not any problem even with the automatic partitionning.
I must have Zorin 17 Core because of the tablet style menu, i have not this option on Zorin 16 Core and Zorin 16 Pro shows error for disc full even on lite pro version.
I thank you in advance for the help you can provide me.

Error with the boot repair tool > http://sprunge.us/s2etNL

Can you try powering the device down, but hold the power button for an additional thirty seconds after shutdown to attempt to reset the NVRAM. Then power up and proceed with boot repair.

I will try that later, thank you.

Edit 8:08 pm:
Same error with "Locked NVram detected"

I have tested with purge GRUB before reinstall in advanced options in repair boot tool too but i have the same error.

Latest error report with purge of GRUB > https://sprunge.us/Kik81E

I will reinstall Zorin 16.3

No problem with Zorin 16 Lite