Zorin 17 Core not working

Hello
I have a Dell Precision M6500 that I have not used since quite a while. I have used Zorin 14 and Zorin 15 in the past if I recall correctly.
For Zorin 17 I cannot acces the live install except if I use safe mode. I suspect it's the hated Nvida card causing the issues as the normal live install hangs with a few small colored dots. I initially investigated some errors regarding ACPI but they are just some warning.
Of course after the install completes and laptop restarts it hangs on the same spot. Should I use nomodeset or something else? I have tried to install proprietary drivers on second install attempt but no change.
This laptop has an issue with the 6.4 kernel; no problems at all on 5.15.
Thank you in advance for your kind help.

Just wanted to add that Using an other distro (Bodhi Linux) with new kernel (6.4) has resulted in the same behavior.

Could You try it with Zorin 16? There You have the 5.15 Kernel.

I could but Zorin OS 17 is so much better.

My Idea was that You try to install Zorin 16 and see if it works. And when it works You could use the Zorin Updater Tool to Update to Z17.

1 Like

I had to go this route on my old laptop, ZorinOS 17 would run fine during live boot and the installation seemed to go well, but then it wouldn't boot properly. I re-installed Z16 and used the Upgrader, and it worked fine from there.

Alternatively, you can try this out which I mean to do before the news of the upgrader being released:

1 Like

Thank you for your suggestion. I'm 100% Zorin 16 would work but I don't want to upgrade, I want a clean install.

1 Like

If the Safe Modes works You could try the Installation with this and then use the Mode to update the installed System. Then You should have the 6.5. Kernel. You could test it with that and if it still not works install a newer Kernel.

You wrote that it was with proprietary Drivers not better but may be the Combination of a newer Kernel (6.5 or higher) AND the Drivers could help.

Hi and thank you for the suggestion. Unfortunately for me "normal" live install doesn't work.. only safe live install session.
I installed Zorin 17 as a dual boot with Win7 (the laptop has a licence for it). I've then tried Bodhi 7.0 "s76" that ran into the same problem and then tried the "regular" Bodhi which works fine. Difference between those 2 Bodhi linux version is the kernel, otherwise they are identical.
Bodhi runs fine but it's not easy for a beginner and I want to sell the laptop, as it was not used for a lot of time... I only us high resolutions ultraportables (Fujitsu T904/U904) and a newer Inspiron connected to a 4K resoolution screen that runs Zorin 16.
Other than high power consumption the Precision M6500 is very high quality laptop, much better than new generations of laptops.
Zorin is a great OS for those wanting to do the switch from Microshit to Linux.
While initially (25+ years ago) I really like Nvidia now I hate them for the ■■■■ they're doing and for being so closed-source as they are (as opposed to AMD).
I'm now on my second wipe SSD (Samsung 500 GB) and installed Win7 so I want to succeed installing Zorin 17.
Thanks again to everyone wanting to help; I appreciate it.

1 Like

Hi

Thank you for your suggestion, however as explained in my above post (completed after yours) I don't really want to experiment. What I would need to know is what is the exact difference between safe mode and normal mode and repliate that for the install. As I said 5.15 kernels works fine, unfortunately there is no easy mode (that I know) to choose these series of kernel. Linux Mint had a tool for installing kernels but I dont think it works in Zorin.
Also I see little benefit to use a new kernel on a >10 years old laptop.

1 Like

The Safe Mode starts with Nvidia Drivers as far as I know (Icannot verify because I have an AMD APU)and You can choose Kernels but I don't know if the Choice is available in the Installation Medium.

Yes, that is a Feature what I find realy good, too on Mint. Zorin don't have that but You could install a graphical Interface to install Kernels. It is called Ubuntu Mainline. For that You must add a Repo because it isn't in the Standard Sources.

Hello
Thanks Ponce-de-Leon for the good suggestion. I installed Zorin OS 17 and booted first time trough safe mode. I've updated from 6.2 kernel to 6.5 and now it works. Im writing from the Precision.
I think I have tried 2 times to install Zorin OS 17 with and without checking install additional drivers. Now I left it unchecked and it works; it might have worked even with normal boot but I have not dared to try.
Now to remove as much as possible from the bloat included.
First impression from Zorin OS 17 is that system is quite sluggish (and it shouldn't). But it's a nice friendly OS for beginners and that's all that counts.
I installed mainline but last kernel (6.7.3) didn't want to install properly because of a missing dependecncy. I've found that ukuu is now a paid solution.

1 Like

It's running better now. Quite nice! I didn't know I'm running Wayland.. cool(er)!

And there was less bloat than expected.. cool again! Congrats to the developers!

1 Like

In Zorin 17 Wayland is default. If You want change that you can do it on the Login Screen. Click on Your Account and the Password-Field appears. And when it appears You have in the bottom right Corner a Gear Icon. Click on it and You can change to X11 if You want this.

But the Main Point: It works now for You. I'm happy for You that it runs.