Zorin 17 install only using 256Gb of HD space

Installed Zorin 17 on Dell Latitude e5430 with 512 Gb drive, but it only using 256 Gb in a partition. Here is the result of sudo lshw -C Storage

Please advise.

Can you launch Disks and share a screenshot of how this drive looks like from there?

1 Like
  • Do you have 2 different drives? 512gb and 256gb?
  • Or you have only one drive Size of 512gb out of which Zorin is showing 256gb only?

Sorry I made a mistake earlier when asking for the output of the lshw command.
It's is:

sudo lshw -C disk

I'm hoping this is the correct lshw command to check drives. I don't have my Laptop right now to confirm this.
otherwise use this command:

inxi -Fxxxz

And just as zenzen has mentioned a screenshot from Disks.

Topic previous to this topic for reference: Invalid partition table after 17 core install - #29 by windswords

Hey guys,

Well I turned on my machine this morning to fullfil your requests. The first thing that happened was I got Invalid partition table! message again. Ugh! I don't know why. The last time I changed the boot to Uefi (details in the other thread) it worked and I powered down and back up to make sure.

So I pressed enter (what else can I do?) and instead of going ahead and booting I got this:
Broadcom UNDI PXE-2.1 v15.0.12
PXE-E61: Media test failure. check cable
PXE--M0F: Exiting Broadcom PXE ROM.
No Boot Device Found. Press any key to reboot the machine

So I pressed enter again. Same thing. So I entered the BIOS and did a diagnostic.
Not much help. Everything checked out including memory, processor, system Mgt, Fan, Video card, OS Boot Path 0, hard drive 0, CDROM, and interesting - "cables" (it doesn't specify which but shouldn't that include the cable for the wireless adaptor?), the only thing was it said my battery was nearing the end of its useful life (no surprise).

So I GUESS my wireless adapter could have just crapped out, BUT did that cause the return of the Invalid partition table! message? And when this machine was running Win 7 it never had a problem with the wireless modem, not even once and that includes the day before I started installing Zorin 17 on it.

I have Win 7 installation CD. I might try to put Win 7 back on the machine and see if the wireless is still a problem.

In answer to your question there is just one 512 Gb drive on the machine, a DVD/CD drive and three USB ports. That's it for mass storage.

Addendum - for giggles I went back into the BIOS to look at the Boot sequence etc. I also remove the back cover and re-seated the wireless adapter (found a YT vid on how to and shockingly, this Dell is logically laid out and the adapter easy to get to - 2 screws and its right at your fingertips.

Anyway, I go back into the BIOS and it is set back to legacy/mbr! I SWEAR I did not touch it.

So I reset it, rebooted and of course no invalid partition table message, but also no error on wireless. After Zorin fired up I went into settings and the internet connection was just where I left it. Of course that doesn't mean it will stay that way... Makes me wonder if my machine is haunted...

So back to the disk partition issue - I ran inxi. A lot of info returned, but here is the part about the disk drive:

hd 2 image



Can you also do this for zenzen.

This means it's trying to boot over the network. But wireless is not usually available at this stage in the boot process, and without an ethernet cable it explains the "media test failure" error message.
PXE is usually down the list in the boot order, so something must have caused the system to fail to recognize a valid boot device elsewhere. I suppose hardware showing its age can be one reason, or maybe some excess dust accumulated inside. A good cleanup from time to time with a can of compressed air and isopropyl alcohol can do wonders.

That screenshot shows the temperature of the CPU at 49 degrees. That seems quite high for 12 minutes of uptime. For reference, I have a laptop with a few browser windows, Docker and the occasional virtual machine (currently none running) and temperature stays at around 40 degrees. This makes me think that cleaning any excess dust may be a good idea even if it's not the cause for this particular issue.

Also, please the screenshot from disks would be helpful just to see how it's reading the drive.

1 Like

Sorry with everything happening I forgot about the Disks screenshot here it is:

1 Like

It's surprising that it's detecting this as 250GB a drive, but it's actually 512GB, right? There are a few mentions of it being set on RAID mode though, I suspect this has something to do with it, but I'm not really sure what that means. Have you made any changes explicitly for this to be setup in this way, or perhaps you are dual booting Windows and Linux?

Searching online I found a few threads that point to this as the cause for similar issues. This one in particular was solved by switching from RAID mode to ACHI in the BIOS.


Also, do you see any output when you run this in terminal: sudo dmesg | grep -i raid?

yes, only 1 512 Gb drive. It has never been set up to be a dual boot machine to my knowledge, but I did buy it refurbished, it came with Win 7 64 bit and it used the whole 512.

Here is the output of dmesg:
1.772651] ahci 0000:00:1f.2: AHCI 0001.0300 32 slots 6 ports 6 Gbps 0x33 impl RAID mode

I'm afraid at this point your guess is as good as mine but if you are willing to try, you can switch this mode to ACHI in the BIOS. I would backup whatever important data you have in this drive first, just in case. And btw, are you using this drive to dual boot both Linux and Windows, or some other distribution?

No just running Zorin 17.1. I tried both disabling RAID and switching to ACHI. I still get only 200+ Gb of usable space. Is there a utility (windows or linux) that can low level format a drive and wipe out the partitions etc. and then make it just one main partition save for the few Gb for the boot/OS loader? If so I need to know what Zorin needs (GPT, UEFI, MBR whatever) to successfully install. What bugs me is that everybody says that linux is great for older machines - mine was manufactured in 2013 - I could understand if it was 2005 or 2008...

This stuff is admittedly out of my league. Would a computer shop be able to do what I asked above?


You should be set to AHCI, not RAID.

You can set this directly in the BIOS Settings of the computer, regardless of which OS you are using.

You can format or re-partition a drive in Windows OS by using the Windows partition manager or in GnuLinux Zorin OS by using Gparted. Either of these options is functional and each application is pretty equal to each other in regards to usability.

A shop undoubtedly could do the work. You also can do the work. Daunting things to learn always intimidate us. But to be empowered is to recognize your capabilities to learn and adapt.

If the drive is showing as 256 gigs... Uhhh... that is the drive size. I cannot think of anything in GnuLinux that could misrepresent that.

Manufacturers of USB sticks get busted for selling a USB Stick labeled as 64gigs, when in reality, they took a 32 gig stick and then programmed it to read as a 64 gig, allowing them to sell a cheaper product at a higher price. The customer often does not find out about the switcharoo unless they fill the drive.

What make and model Drive is it?

I don't understand. Your Disks screenshots (here Zorin 17 install only using 256Gb of HD space - #9 by windswords) are saying the drive is a HFS250G32TND-N1A2A.

A websearch for that dive finds this: Amazon.com
The Spec on Amazon is confiusing as it says Density: 120GB/250GB/500GB
but is listed as a 250GB device.

From the other thread:

You are saying when you had Win7 on that same drive, it was showing the full 500GB?

1 Like

As with most things, your mileage may vary. But consider that despite this, you are still running a modern operating system that receives updates. "Linux" is a very broad term and there are other distributions that are designed specifically even for 32-bit machines; I myself have an old Toshiba from 2007 that still runs... except for the fact that the power cord needs to be taped to the desk but that's another story :joy:

@zabadabadoo brings up a very good point, as I'm also not seeing results online for this particular brand and model that offer more than 250GB of capacity. From the manufacturer's website:

Are you sure this drive is really 500GB in size?