Zorin 17 issue with hiding panel?

Hello.

I recently upgraded my HP EliteDesk 800 G3 from Zorin 16 to 17 and noticed an issue with my taskbar panel that I normally like to keep hidden all the time.

The issue appears when I open Taskbar Settings, go to Panel Intellihide options, and then unselect "Only hide panel when it is obstructed by windows" (keeping panel hidden unless cursor goes over it).

After having done this, it becomes impossible to bring up the right click menu to do something like "pin" a program to the Taskbar because the whole panel immediately autohides right after the menu pops up. I'll right click over a program, the menu appears for a moment, and then the whole taskbar hides right away.

This issue disappears if I unselect "Only hide the panel when obstructed" so that the panel stays up all the time (unless a window is over it).

Any idea of how to fix this?

That seems to a bug, I think, as I'm seeing the same behavior.

For a temporary workaround, press the Super key (the Windows/Cmd key) and that will bring up the activities overview. Search for Zorin Apperance -> Interface -> Left Super Key and set it to Zorin Menu. This make it so that the menu will appear when you press that Super key, along with the taskbar. Incidentally, the Taskbar settings are also found in that same window.

If you still want to bring up the activities overview using the Super key, press it twice.


EDIT: my slow brain has just now processed the words from this post. "Only hide the panel when it's obstructed by windows" should be enabled if you want to show it by default, but hide it once a window overlaps with it. If you disable this option it effectively removes the taskbar until you bring it back up yourself, mainly by the method I described above of pressing Super.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.