Zorin 17 on dual boot suddenly not booting anymore

I made the upgrade from 16 to 17 a while ago on my dual boot machine, all went perfectly well. I can still choose whether to boot Win or Zorin from the Grub menu but now, when I choose Zorin this error appears:

BusyBox v1.30.1 (Ubuntu 1:1.30.1-7ubuntu3) built-in shell (ash)

I tried starting Zorin in recovery mode (?) and this is what appeared on the screen:

Windows is unaffected as they are both installed on different drives

Anyone got any hint on what to do next?

The fact it is asking you to do a fsck (file system check) might be due to an orphaned file from Z16 or (hoping it isn't) potential drive failure. Boot a live mode of Zorin if possible, then run Disks Utility to do a SMART test:


Sorry for the late answer. Been on vacation in sunny Mexico! :sunrise_over_mountains:

I ran the SMART test from live mode and the result was 100% fine. But still, the same error occurs when trying to boot Zorin 17.

I would boot off a live media of Zorin, unmount the offending partition and run efsck on it. I will need to look up the exact instructions as I think there is a bit more than just efsck for the command.

Update: follow the guide here:


Thanks, swarfendor! That did the trick. I simply unmounted the drive, ran fsck manually without -a or anything of that kind and indeed there were orphaned files and other errors that could successfully get fixed by the command fsck. All I had to do was saying "yes" to everything :smiley:
Thanks again, I am writing this from my repaired Zorin 17 drive on my dual boot machine!