Zorin 17 ZFS Question and Install Frustratons

I am trying to install Zorin 17 on an HP Z800 which has hardware raid (mirrored disks). Also Zorin 16 is installed and I want version 17 installed along side. The install fails dismally. So I have some questions and may be observations.

  1. It appears the install has tried to setup ZFS on the new partition. Its my understanding the installation of ZFS on hardware raid is asking for trouble and is not recommended. Although I could setup the Z800 to not use hardware raid that would mean a lot of time and effort in moving my existing 16 install and all the associated backups. Its not happening.

  2. Even though I chose the install along side option it appears grub setup fails. I need to collect more information on this and will update as I get it.

  3. I have tried three times to run the live trial but it bombs. Again I need to collect more detail - to follow unless I successfully get Zorin installed. Or drop it.

Further observations:

  1. when the installer boots and displays "Checking md5sums: 0% complete ...... Press Ctrl+C to cancel .....", is unresponsive for sometime, does not provide a good user experience. Particularly after booting for the twenty-ninth time.

  2. Problem: from the choose to test or install zorin if choosing to test the desktop disappears and displays the boot messages. If "safe drivers" were chosen then the screen continuously clears followed by the same and unchanging boot messages. If nvida drivers are chosen then the boot continuously updates with:

nnn,nnnnnn] NVRM: the NVIDIA Quadro K400 GPU installed in this system is
nnn,nnnnnn] NVRM: supported through the NVIDIA470.xx Legacy drivers. Please nnn,nnnnnn] NVRM: visit http://www.nvidia/object/unix.html for more information. nnn,nnnnnn] NVRM: The 535.129.03 Nvidia driver will ignore this GPU. Continuing probe...

NB: "nnn,nnnnnn" are three numbers followed by six number eg: 768,699728

Clearly its not ignoring the GPU but loops.

  1. There is no option on "Install Zorin OS alongside Zorin OS 16.3" to not use ZFS. Also when continue is pressed and the "Write the changes to the disks?" pops up. The presentation is confusing and meaningless to a new user. I cannot tell if its going to use the correct partition let alone the correct disk. and what is ESP? (are yes, its Extra Sensory Perception).

Hi, do you not get the option to do a manual installation? I'm sorry I can't help with the RAID issue as have never used the setup. ESP is referring to an EFI partition which needs to be placed inside of a /boot partition an marked /boot, esp/efi, based on my recent conundrums with kde neon reinstall on a new HDD. Here is an old article about ESP:

Did you check the SHA256 checksum of the downloaded Z17 .iso file with the published value?

The Zorin OS Installation does not default to ZFS. It defaults to ext4.

Thanks zabadabadoo for responding.
I did not check the download against the SAH key but I did allow the checks on he file system to run and no issues reported. However I do have some further updates to my trials and tribulations.

Thanks swarfendor437 for responding,
I think the EFI is mu problem.

Further updates:

item 1 and 6. Install on ZFS Partition: I have not been able to recreate this but it could be due to a previous install that is likely to have done.

item 3 and 5. Running the live desktop.
I have since discovered that If I just let the Grub default to run then I can use the live desktop. This allows me to run GParted, Grub Recover, and the Zorin install.

Finally: I have managed to install Zorin 17 and Grub was configured, Both Zorin installs were identified and in the Grub menu. However when I tried to boot either version I just presented a black screen. I could also use Crtl+Alt+Del directly to reboot.

I Used GParted to look at the install and noticed: /dev/sdb1 was a FAT32 with boot and ESP flags. Also the Zorin 17 was installed in an Extended partition.

I run the Grub Recover and it reported "Boot Recover fails because its in BIOS-Compatibility mode.

My thoughts are that Zorin install thinks my HP Z800 supports UEFI and it most definitely does not.

Aravisian's tutorial might help?

Thanks swarfendor437, I'll take a look.

Hopefully the Zorin Developers will address this issue in order to make the installation easier for newcomers.

Well I eventually got Z17 installed and dual booting with Z16. I have to say it was one of the most painful experiences I have ever encountered when installing.
BEFORE DOING ANY STEP BACKUP THE DISK (Rescuezilla is your friend)

a) Install Grub Customiser in Z16. Deleted apps no longer used and any old files.

b) Reduced the Z16 partition size using GParted.

c) Used GParted to create a 512Mib partition formatted to fat32. Created an extended partition. Created a logical partition within the extended partition whose size is slightly larger than the Z16 partition.

d) Opened a terminal and used dd if=/dev/sdc5 of=/dev/sdc3 to clone the Z16 partition. When complete, deleted the original Z16 partition.

e) Used GParted to move partitions around and make a empty partition into which Z17 will be installed.

f) Booted Z16 install media and run the boot recovery. Check Z16 now boots AND make a backup.

g) Boot the Z17 install media and install. Make sure the Install alongside Zorin 16 is selected. I could not get the Grub boot loader to install properly at this point. I therefore opted to complete with out a boot loader.

h) I Then booted the PC into Z16 and used the Grub Customiser to set-up Grub.

I checked boot into both Z16 and Z17 also made a system backup. This allowed me to look and tidy up the Z17 install as is created an empty partition which was not needed.

My only remaining problem is a ridiculously slow boot time.

Finally many thanks to those who tried to help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.