Zorin Appearence missing some options

When I go to Zorin Appearence under layout there's absolutely nothing.

Something caused gnome-shell and a few other packages to uninstall, one of those packages being zorin-appearance-layouts-xfce-core. I tried to reinstall everything I could find that I would need but I don't know what packages I'm missing.

When I run sudo apt-get upgrade this is the list of packages says are no longer required.

  • folks-common
  • gir1.2-camel-1.2
  • gir1.2-ebookcontacts-1.2
  • gir1.2-edataserver-1.2
  • gir1.2-folks-0.6
  • gir1.2-gdata-0.0 gir1.2-gee-0.8
  • gir1.2-gsound-1.0
  • gnome-shell-extension-zorin-appindicator
  • gnome-shell-extension-zorin-dash
  • libfolks25
  • libgee-0.8-2
  • libutempter0
  • linux-headers-5.4.0-47-generic
  • linux-hwe-5.4-headers-5.4.0-47
  • linux-image-5.4.0-47-generic
  • linux-modules-5.4.0-47-generic
  • linux-modules-extra-5.4.0-47-generic
  • sshfs

Zorin OS Core uses the Gnome desktop which uses Gnome-Shell and Zorin OS Lite uses the XFCE4 desktop which does not use Gnome-Shell.
Are you using Zorin 15.3 Core or Lite?

If Using Core (Gnome Shell / Gnome desktop)
In terminal please run:

sudo apt install zorin-os-desktop

I'm using Zorin Lite, before I installed gnome-shell it stopped booting with gui and I'm not completely used to navigating a computer with no ui.

The screenshot you showed is of Gnome version (CSD) Of Zorin Appearance.
As I recall, Zorin OS lite does not have Zorin Appearance as an app, but instead has Settings > Appearance.
For right now, there seems to be a Mixing of Desktop Environments and given that you started out on Zorin OS lite, I would suggest with going the Safe route of:

sudo apt install lightdm

sudo apt install xfce4

This should restore access to your GUI desktop. I am a bit concerned that you have "unneeded" kernels listed- can you clarify which kernel you are using? You can use the terminal or tty command

uname -a

to find current kernel.