Zorin Black screen after login

Zorin do love black screen. I had face black screen during shut down, restart and suspend. Although old kernels have fixed the issue but it's a nightmare now. I now when I put my password on login screen the screen gets black and nothing comes.

This started happening when I reduced the resolution quality in settings.

Not gonna lie, I ran into too many problems that I haven't even used zorin os previous month.

It's just unusable.

What happens if you set them back?

I think everyone feels this way about every distro at one point or another.
I know I have.

1 Like

I can't set them back since after I login black screen appears nothing I can do after that except trying ctrl+alt and some function key which brings me back to login screen

Enter TTY instead.
ctrl+alt+F5

This will get you to a terminal. You can use xrandr to set the resolution

xrandr

Grab the Monitor Identifier. It may be VGA-1 or HDMI-1 or DP-1... In this example I will use DP-1. Replace that with your actual identifier. Replace the resolution with the last known working res.

xrandr --output DP-1 --mode 1440x900

It says can't open display.

Are you using Wayland?

Did you type the command correctly? Please show a screenshot of

xrandr

Run in terminal, followed by a screenshot of the command you ran.

Is there a command to reset display settings?

Can you try

xrandr -d :0 -q

Instead of xrandr and see if that works?
If it doesn't... (Your profile lists that you are using both Lite and Core...) In Zorin OS Core (gnome) the configuration file should be
~/.config/monitors.xml

In Zorin OS Lite (XFCE), it is ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml
If you are unsure, you can check with the command sudo find . -type f -name "*displays*"

You can use the mv command to rename them to a Back-up, allowing the system to set a Default Configuration.
For Zorin OS Lite:

mv ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml.bak

For Zorin OS Core:

mv ~/.config/monitors.xml ~/.config/monitors.xml.bak

Once done, reboot and test.

1 Like

I'm gonna use window this month since I have some work to do and literally don't have time to fix zorin os.

I'll update here after one month when I get free.

Thanks for helping..

Hi none of it works.
Besides is there a command to reset whole zorin os?

No, you can perform a Reinstallation of Zorin OS.

Had you tried rolling back to a prior kernel?
Had you checked your Graphics Drivers?
Had you tried reinstalling the Display Manager?

1 Like

after doing the mv command does it suppose to show something like processing

But it didn't Showed anything.?

After too many restart zorin starts working now, I think the problem was related to display power scaling which doesn't fit with my gpu compatibilty.

thanks!

I hope I don't run in any problem in future soon.

2 Likes