Zorin boot animation was replaced by Pop OS animation

Recently I installed Pop OS icons via PPA (system76). Then after some time Software Updater popped up saying there are some upgrades available. I blindly tapped on Update and the whole Pop OS desktop environment was installed. After a reboot I realised that I made a mistake because Pop OS took over the boot process. In Grub, it showed Pop OS instead of Zorin in the first option. After choosing it, the boot animation showed Pop OS in very small sized font and 4 orange animated square dots down below it. Then Zorin login screen loads.

I hate Pop OS DE so promptly removed everything related and disabled PPA as well. After update-grub the boot menu was changed to Zorin again but it does not have 2 options now Memory test & UEFI Settings. Not very important but somehow feels something is missing.
So, first question - how to bring those options back?

Secondly, the boot animation is still not changed. It is still the same as explained above. I went through related topics on Zorin Forum but nothing helped (maybe I missed any post related to this). I do not have NVidia and I installed Zorin Plymouth theme as per one of the forum post.

Just wanted to know why a PPA which I added for icon theme has made such a mess. Is that the default behaviour?

I found a comment (by @Aravisian ) that might help with my question #2. --> Changing Plymouth splash screen - #5 by Aravisian

Will check and update.

Yes, that should help you.

In addition, for Grub Menu, check your grub file:

sudo nano /etc/default/grub

At the very bottom, your Grub theme should appear as:


Ensure it is present -or re-add it if needed. Ensure it is not commented with a # symbol at the front of it.
Once you have made any needed changes, do be sure to run sudo update-grub again...

In addition, please see this post:

for another tip on checking /var/log/ for installed or upgraded packages through dpkg.
This may be helpful for finding any other remaining changes that could haunt you later - such as a package that you wouldn't remove having been upgraded according to Pop_OS repos, but not to Zorin OS Repos. That could causes you mysterious headaches later after this event has faded in memory.

1 Like

Yes, that helped. I didn't get the actual Zorin boot screen but a different one with a big Zorin logo in the middle.

Yes, I checked that before as well. It was enabled. Memory test & UEFI Settings are still missing though.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.