Zorin clean install goes awry! Any help would be appreciated!

The PC in question is an Asus T100TA 2in1 Transformer tablet: Intel Atom Z3775 proc, 2GB RAM, 64GB ssd.
Hello all,
I've been using Zorin 15 for several years now and was very much looking forward to trying 17Core.
I backed up all my files and made a flash drive to load 17. Used the "try Zorin" to check that everything was working as it should be (worked perfectly and many nice improvements). Satisfied with the results I chose the install option and things went bananas! B-A-N-A-N-A-S!

Setup would get about 75% of the way through and then I would get a fatal error.


Unsure of what to do, I grabbed a fresh copy of 17, checked the file integrity, flashed a different USB stick and tried again. Same error though the # changed from a 1 to 2 for some reason.

Gave Zorin 17 lite a try. Same result, the "try Zorin" works splendidly but it absolutely will not install.
I looked around online and found the suggestion to try the built in "Boot Repair"
under the "try Zorin" environment. No luck there, the installation would say it completed but the installer clearly crashed.


Well since I had a full backup of my files and nothing of value on the machine that I minded losing I thought I would try some of the advanced option to see if they could fix the problem... Spoiler Alert it actually made things worse!

I followed the following instructions given by the advanced "Boot Repair" copy/pasting all the text into terminal exactly as it showed here (including using tab and enter to say yes to that window).

Afterwards I got this message saying NVram is locked?

Finally now when I pull the flash drive out and hit enter to reboot there is no longer anything to boot from! No SSD shows up in the BIOS, nothing.
This...


became this...

Apparently at some point my SSD became invisible to the BIOS (ohnoz!). Not sure what to do but my first priority would be to get my SSD to show up again (if anyone knows how to make that happen I would be hugely grateful!).

From there I can keep trying other options but at the moment I can only run the system in a live environment. Everything resets on reboot and it just dumps to BIOS if I take out the flash drive. I sent the email requested to boot.repair@gmail... what's next?
I am open to suggestions for how to get my SSD back and or what I need to do to make Zorin install properly. Apologies for the long post and thanks in advance for any help!

Welcome here!
Sorry to hear about your pc.
Can you use Erase Disk and Install Zorin option? (I think you have a backup)?
Also did you use manual partitioning earlier?

If you have an UEFI bios and GPT disk, then you will have to install GRUB to EFI partition.

Erase Disk and Install Zorin would help you.

Have you checked in BIOS that secure boot is disabled?

Are you still able to boot the Live USB?
If true, can you try Disks app and see if the SSD is visable at all?
another option would be try Gparted to determine if that can see the SSD.

1 Like

Thanks! And thank you for your reply.
Appreciate that.
Each time I attempted to install Zorin I used Erase Disk and install.
No, I did not manually partition or try to install along side another OS or prior failed install. I wanted a clean install so I only ever selected Erase and Install.

Yes I have a full backup so there is no data loss to worry on I just do not know how to get my SSD to reappear and/or how to get Zorin working.

It is a Legacy BIOS, no fancy GUI or mouse support.

The Zorin USB flash disk now just dumps to BIOS screen where the USB shows as the only boot option and if I pull it there is no boot option.

Strangely, I had Linux Mint Debian Edition (Faye) on another flash disk, as my backup plan if I could not get Zorin working, and, unlike Zorin, it will load a Live session but only shows the flash drive itself as an option for install. My total guess as to why is perhaps Zorin checks for a drive to install to doesn't see one and resets back to the BIOS where as Mint does not perform the check or counts the flash drive itself as a viable install point and so allows the live session?

Hello! Thanks for your reply.
Yes I checked beforehand and throughout that both Secure Boot...

and the "trusted" platform module were disabled.

No. Alas a Zorin flash disk installed and selected as the (only) boot option dumps right back to the BIOS screen. Strangely though a LMDE (Faye) flash disk, my plan B, will load a live session but only shows the USB drive as available to install upon.

In theory this makes a terminal available to me in Mint that I could run commands from if anyone knows what to run to make my SSD reappear.

Yes I can try, I am not familiar with with Disks app or Gparted (I assume a partitioning utility?) are these in Linux natively or do I need to install them with "sudo apt" commands?

For reference I have used a couple of Linux distros (Ubuntu MATE, and Zorin primarily) for many years and I know how to set them up, run them, and keep them up to date but I've not had to troubleshoot any big issues like this so I still do not know much syntax beyond update, upgrade and install.

Edit**
Did some digging and answered my own question, both "Disks" and "Gparted" are native in Mint and this is what they show respectively...

Also before I realized my SSD was gone when Mint gave the install option I went through with it (both the SSD and Flash drive are 64GB)... it took forever to run, like ½ an hour instead of 10 min or so but I believe it successfully installed Mint to my flash drive loaded with the mint install lol.

I had similar errors when trying to install Zorin on a machine. After many attempts I discovered that the problem was with the Pendrive/memory card used to create the installation.

I tried with 3 different pendrivers and each time switching between Rufus and Balena Etcher.

What worked to install on this machine was one of the pendrivers created with balena.

1 Like

Something I found strange is that mmc (mmcblk1) is a correct name for a partition on the SSD?

Edit: As mentioned below I saw that this device uses an eMMC. So this correct naming as mmcxxx.

1 Like

Thanks for the suggestion! I used two different flash drives for Zorin 17 and Zorin 17Lite (overwrote Lite with Mint) but I do have more I can try out once I get my SSD back in the BIOS. I used Balena Etcher for all three but I have Rufus as well.

What should it be?

Please forget this. I thought it might be installing in another location.

I saw that this device uses eMMC type memory. So everything is correct with the partition name.

Oh, okay thanks.

Perhaps a more salient question might be, in the immortal words of Urkel,
"Did I do that???"
That is, are any of the terminal commands I entered or the advance Boot Repair the cause of my eMMC storage disappearing? If so are there commands to undo or reverse what I put in? Here again is what I copy/pasted...

Yes that window appeared and I responded "Yes" to it.

So back when I had two boot options...

and one said [ubuntu] (funny because it was Zorin 15 and not anything by Canonical) and the other was the SanDisk flash drive did my attempting to fix GRUB make the "ubuntu" drive vanish?

This screen shows the Boot order, not necessarily the machine's disks.
What does it show on the Main tab?

PS: Zorin is based in Ubuntu.

It never showed up in the main screen. (shot before upgrading to 17 attempt)

Only the Boot tab and the Save and Exit tab. It is a very limited BIOS.

P.S. Yep I was aware, and Ubuntu and all it's subdivisions are based on Debian. It's just funny to me Zorin doesn't have it's own designation in the BIOS.

The bootable partitions are listed in these tabs.

If "[Ubuntu]" is the installation you did on the eMMC/SSD then you have not lost access to it.

It's strange that it's not showing the device in the disk manager.

Edited above post. The above that pic was snapped before I attempted to upgrade to 17.

I was on Zorin 15 and everything was working fine I'm just the kind of guy who snaps pics of all the individual BIOS screens just in case.
It looks like this...

and this now...

Boot repair asks if you will "Remove GRUB 2 from /boot/grub ?" and you hit [Yes].
So I think that removal of Grub maybe significant.

Note. if you can boot ZorinOS Live Disk tp "Try Zorin" you will also find Disks and Gparted apps there as well as on the Linux Mint USB.

From your Gparted screenshot. Top right. there is a dropdown beside "(58.25GB)" does that show another drive?
(Asking because when I did websearches yesterday, some users with your problem said device showed in Disks or Gparted but not in BIOS.)

1 Like

There's the crux of your issue. This another Cursed Device™ like my Dell Venue 11 Pro. The official Debian guide confirms it: "The T100 is a mixed mode EFI system (i.e. a 64-bit CPU combined with a 32-bit EFI)"

Zorin, due to its Ubuntu base, has not supported 32bit machines for a while and that includes only being able to install a 64bit grub.

The good news is that if you install a 32bit grub manually or by using another OS, such as the official 32bit version of Linux Mint Debian Edition, then you can install Zorin again after that and it should work - at least, it worked for me, as Zorin just added itself to the existing 32bit grub rather than trying (and failing) to install its own 64bit version.

Alternatively, you may be able to adapt this T100TA-specific Linux Mint guide (not necessary for the 32bit Debian Edition, only their main version which is also a 64bit-only Ubuntu base) to work with Zorin's installation media right out of the gate.

https://forums.linuxmint.com/viewtopic.php?t=417076

Disclaimer: I don't have a T100TA and so cannot test this guide, but it is very recent with a good amount of discussion and positive feedback, it seems.

2 Likes

Inclined to agree Zabadabadoo, losing the drive in BIOS so soon after trying to repair the boot being unrelated seems to stretch coincidence.

I cannot Zorin will not boot a live session but Linux Mint Debian Edition (my plan B if Zorin didn't work) does boot a live session from the flash drive.

It does!

It shows Mint on it.

After Zorin17 and Zorin17 lite failed multiple times and after the boot repair options failed I tryed running LMDE and it did complete but as soon as I take the flash drive out it dumps to BIOS and shows nothing.

Edit
By pulling the flash drive and seeing what disappears, it seems that /dev/mmcblk1 in Gparted and HCG8e_ in Disks are the same device (sorry for my ignorance with this)which is the eMMC storage drive in my T100 and that it is still intact and shows up in both programs.

The million... err make that the $12 question (don't have a million in my pocket) is how do I get it to show up in the BIOS and become bootable?

There's a lot to unpack here, I will read over the links you say and see what I can learn. In the short term though thanks for your post and helpful links! I was not aware I had a "cursed device" As it has been running Zorin 15 perfectly fine for many years.