Zorin connect copy and paste

Hello, Is it possible to be able to copy and past screenshots into the text message window on zorin connect?

I have used the screenshot tool that comes with zorin and I have downloaded flameshot, but neither option will paste a screenshot into the text message field.

Thanks for any help!!

1 Like

Hmmm... I am using XFCE desktop on Zorin OS 16 Core.
Zorin Connect is built for Gnome, so I cannot use Zorin Connect on the XFCE desktop. So, I use KDE connect, instead.
GSConnect gnome extension is based off of KDE Connect.
ZorinConnect is based off of GSConnect.

So, yes, on KDE Connect using Zorin OS< I can and do copy or paste in the reply window for text messages including images. (And just tested it to be sure.)
I do not know if Zorin Connect does as well without testing it... Are you experiencing differently on yours?

Zorin OS 16 pro Gnome desktop

In Zorin Connect copy and paste works for only text. Using a screenshot that
copied to clipboard does nothing, paste is grayed out in messaging window of Zorin connect.

However, I tested using the same copied screenshot and pasted to the body of an email, to confirm the screenshot actually copied and it worked.

1 Like

If someone texts you and you open the text on your phone while in front of your computer, then you copy the image - do you see a popover on your phonescreen that says "Copied to tray" and shows a small window with a clipboard icon and a url?

I dont....initially when they sent the pics just now the msg thread automatically disappeared on the zorin connect msg screen. I had to add back manually. Once I added the thread back the pictures only display a small blue bubble with no image inside

On my phone when selecting the pic, I do not get a copy option any longer. Previously sent pictures I do get the copy option when selecting, but only the copied popover is displayed and nothing else.

For my own perspective- I think this is the information I am looking for... As I am running kind of... My own modified setup... It makes it harder for me to test (Or always remember) other standard set ups.
Are you stating that a function you used to have has changed or is missing?

Honestly I dont know if something has changed. I am note sure I have ever tried to copy a sms pic on my phone. Since trying today though it does seem that the only pics I can copy from a sms thread is the ones I have sent.

I have disconnected Zorin and tried coping on phone and get the same result

I just sent a new sms pic from my phone and the thread disappeared again on the zorin message window and once I add back the pic is missing just as the ones I received.

I just did some checking into GSConnect and it is also unable to do what you are testing currently. So I believe it is likely that ZorinConnect - same gnome-extension base- is also the same in this regard.

I then logged out and in on Gnome Desktop and tested it to the same results you describe. (Now back on my daily use desktop) I apologize for the runaround... I really should have done the Actual Physical checking first. I admit... I didn't want to log into Gnome again today...(sheepish)

Unless any other Zorin Connect users chime in otherwise- I am going to suggest it seems highly likely that this is Normal Behavior. You may consider suggesting this as an improvement to ZorinConnect in the Feedback Forum, though.

1 Like

Defiantly seems normal now you are getting the same results. I appreciate you taking the time to reply and test that out.

2 Likes