Zorin Connect Mounting Problem

Hey all,

Has anyone had a problem with mounting your phone with Zorin Connect on OS 17?

I usually like to mount the phone as a drive and move around files in the file system, but since OS 17 I have had problems with it even mouting.

No I am not on a VPN, and I do not even have the UFW firewall running. i do not think those are the problems.

When I go in the Zorin Connect from the bottom right and click arrow - Mount... it looks like something happened but the phone never shows up in other locations or in the remembered locations.

Is anyone else having these problems?



1 Like

I am not familiar with this particular issue, so I tried searching on similar issues with KDEConnect or GSConnect.
I did find several users complaining of this exact same issue - which a few links later led to this proposed solution:

Thanks @Aravisian !

It seems Android needs to fix a bug... I do not really want to connect via command line, just by nautilus for moving lots of files and such. My only question would be this worked on OS 16 no problem. Is Zorin using a different protocal SFTP? or did they use that on OS 16?
I guess I will just wiat until this gets patched and fix if it ever does.

I think it is because Zorin OS 17 is on Gnome 43, whereas the GSconnect and ZorinConnect Gnome Shell extensions were developed on Gnome 3.xx

While they work over-all, there may be some small issues within that need to be addressed.


Is the zorin team working on this or it is more an android thing... Or even gnome thing...

I know it sounds like a small thing but I like to think this feature really sets Linux systems on par with macs and way above windows, as the "it just works" idea that I hear so many Mac users say.


Reading the attached link, this looks like it is something resolvable application-side.
It is important to follow developer structure when addressing a bug. You want one patch to make it through the final process.
It looks like the origin lies between SSH and KDE-connect. Both GSConnect and ZorinConnect are based on KDE-Connect.

Bugs are a part of computing and no bug is small. I could not possibly say what actions or priorities are assigned to a particular bug - I had to research this issue and even speculate a bit.

What we have is a series of teams who are all motivated to provide a service that works well and reflects well on them. The KDE-Connect, GSConnect development teams all want their software to work and the ZorinGroup wants to be the most appealing GnuLinux Windows alternative. So we already know that none of the parties involved will want to sit on their hands.

What I can do, at the least, is ensure that the ZorinGroup is aware of the issue so that they may approach the appropriate action to resolve it.

Thanks @Aravisian

I hope they can find a fix soon.