Zorin Connect ... not connecting!

Well, as you know I stipulated how to use this app in the unofficial manual. Now I am able to use KDE connect with FerenOS which runs KDE 5.18 Plasma without any issue - I even get KDE keyboard option to connect my keyboard via bluetooth.
Now the port I stated in the manual for the firewall is 1714 - when I launch Zorin Connect it won’t go below port 1716! Tried changing the firewall rule in terminal but no joy. KDE connect works great in Feren OS! Have tried looking to see out of curiosity if it would work in LXQt, Cinnamon DE, Enlightenment, KDE - no go and the KDE in Zorin is not as up-to-date as FerenOS, so no joy in using KDE connect in Zorin! :scream:


Always connects for me. Only trouble I had was with using a VPN on the phone or laptop. Set it to bypass the VPN and it worked.

These are my rules, showing running between port 1714 and 1764.
Used the pre-configured


@jgordon thanks for the reply - that’s exactly what I have in the Unofficial manual. It used to work but for some reason when I try to make a freash connection - removed the app then reinstalled via Synaptic and reinstalled the app from Playstore, on the Desktop the lowest port ‘available’ is ‘1716’ - it won’t let me alter that to 1714 even though I have it as an exception in UFW. :wink:
Perhaps it is reliant on ‘snapd’ - which I have just removed following security advice from local LUG co-ordinator - no snapd present in FerenOS KDE. I get drop-outs which I think could be ISP router issue so will see if I can get back to my more reliable Archer 2800 instead of the Fritz!Box 7530. :wink:

On mine, it connects via 1716.
A quick search shows the same for kdeconnect elsewhere.
I really do not think that snapd has any involvement.

1 Like

I will revoke the 1714 rule (1714 works on KDE Connect so surprised not on Zorin!) :wink:

Do you use same port numbers of 1764?

No, I just checked. It is just 1716.

@aravisian - so no need to add the colon and port number when writing the firewall rule (tcp/udp) as I put in the unofficial manual? :wink:

Oh, I wouldn’t go that far. I could not assume that the kdeconnect app changed something that affected the set up procedure drastically in any event.
Offhand, I would suggest that the tutorial included in the Unofficial Manual is fine the way that it is.

Port usage can vary… just as ports for ship docking can. There are many reasons that a port may be unavailable at a given moment (security checks, in use by another app, etc.) that will necessitate KDEConnect or ZorinConnect to use a different port.
Above, I checked a couple times to see which ports were (or which port was) actively in use at the time, given an instance of KDEConnect being used to transfer files and an instance if it sitting idle but connected. I hit the odds that it remained in the same port.

It is a good question why 1716 is shown as the lowest available and that can be looked into further. But my set up includes the same information that jgordon had posted and this had been done solely in one moment in terminal as one command- on a previous copy of Zorin OS that I have since wiped and reloaded and restored a back up on.
So the guide is probably accurate.

Thank you for your tips

I have Nokia 7 plus how to pairing in Zorin. I reading I need open some ports what a firewall blocked? Someone could me help step by step? On Zorin Connect I have only information searching and on Nokia have installed app Zorin Connect. Ok i find installed KDE app on mobile and change rules port in firewall open 1717. Pairing and working. Zorin Connect idk if working properly.

1 Like

I learned that firewall was the reason my device wouldn't find my laptop.

1 Like

yes i wondering firewall blocked connection what want connected with PC. I must checked in app Zorin Connection what port is it and unblocked him but with kde now working this is the same what Zorin Connect i suppouse.

1 Like

i unlock port in firewall but now have this problem.

Cannoct connect

1 Like

Open up a console and type these in

sudo ufw allow 1714:1764/udp
sudo ufw allow 1714:1764/tcp 

And now it should detect it.


Hi, I did cover this in the unofficial manual and there was a separate thread somewhere on this. Not had any issues in Devuan 'beowulf' 3.1.1 KDE with KDE connect. Connects every time - what you do have to be careful of is copy and paste as I have found whilst working from home I managed to copy and paste content from an SMS! LOL!


Thanks, It Worked.