Zorin Connect not working while on VPN?

Hello, I tried to set up Zorin Connect, but it only works with VPN disabled.

I'm using Proton VPN (tried both the native client and the OpenVPN file configuration).
I'm ensuring that both my phone and PC are on the same VPN server (which usually solves the problem in other local network sharing use cases, but no luck here).

I've configured the port forwarding in local firewall, which, as mentioned results in Zorin OS finding my phone, but only if VPN is turned off.

Any ideas left? :slight_smile: I'm not hugely invested in Zorin Connect but it sounds somewhat useful to not have to look at your phone for SMS 2FA and similar things.

1 Like

Have you enabled split-tunnelling? Not sure if they support it directly in the Proton app for Linux yet, their Windows and Android apps have it, but that is usually required for local network visibility.

I use Mulvad via WireGuard and have separate config files with and without split-tunnelling so I can access my NAS and Pi.

Thank you for that starting point! It wasn't Split Tunneling, but Android ProtonVPN has a specific setting to allow local network connections between devices. It's in their Advanced Settings and called 'LAN Connections' and needs to be enabled. Now I can pair. :slight_smile:

1 Like

I'm using Proton VPN too ! (with the OpenVPN config file)

1 Like