Zorin Connect will not find my phone

I am trying to connect my Pixel 2 phone running Android 11 to an 2009 iMac running Zorin OS16 Core. Both are connected to the same home wifi network but the iMac will not find my phone. Has anyone else had this issue and is there a solution?

Do you have UFW (you can open and check with gufw) enabled or turned on?

1 Like

I discovered a post similar to this when I was having the same problem. Consider looking into this post. @jgordon's answer worked for me.

I have Firewall on and will check my settings against JGordon's in the post below. What is gufw?

UFW is "Uncomplicated FireWall."
gufw is Graphical Uncomplicated FireWall. It's just the GUI interface for UFW.

I copied JGordon's layout as mentioned by Elegant_Emperor but it did not work for me.
"Zorin Connect ... not connecting! - #2 by jgordon"

I also tried to uninstall Zorin Connect in the Software app (and was planning to reinstall through Synaptic Package manager) but it would not uninstall.

Try:

sudo apt install --reinstall gnome-shell-extension-zorin-connect

No luck I am afraid. Do I need to restart after running that command?

Did you check gufw?
You can try

sudo ufw disable

Terminal command to just disable it.

You might also try directly setting up the connection through the Zorin Connect App by entering your Computers I.P. address into the device.
Hamburger icon + Pair new device
Or
three dots icon upper right side - Add Device by IP

Will try the command to just disable the firewall. Where would I find the IP address on Zorin and I don't understand the two options? Sorry if my knowledge is not up to scratch here.

In terminal:

ifconfig

Then look at inet next to the connection you are using.

Open Zorin Connect application on your phone and you will see the Icons on the Upper left and the Upper right respectively.

This is what I got when I reinstalled the Gnome Shell extension as you suggested.

2 Likes

Everything there looks good.

That worked thank you. Excellent. Hope you don't mind me starting new topics. Trying to get this iMac running smoothly and keep finding new things that need doing. Will tick solution for this one but have another query about default apps. Will start a new topic for that.

2 Likes

Can you please clarify for future readers which solution you used that worked?
Reinstalling the Zorin Connect extension or Adding the IP to the application?

Adding the IP to the application worked for me.

3 Likes