Zorin Core 16 : Prevent the screen saver while watching a movie with VLC

Hi there,

I'm using VLC to watch movies.
I just realized that the system goes on screen saver mode event when I'm watching a video in full screen mode with VLC (I think it was not the case last week and it might have been induced by the last updates).

Is there any trick to go around that ? (the screensaver option are so few...)

Thanks !

Nah, this is an old problem that gets asked about on occasion...
For me, personally... I do not like the many intrusions of the Screensaver, so I just disable it entirely:

xset dpms 0 0 0

Or

xset s 0 0

If you prefer to keep the screensaver as a functional utility, you can set it to a Longer Interval.

3 Likes

Or you can fool it by running Caffeine. Which simulates mouse movement thereby screensaver never triggers when it is running.
Ref:

That refers to Z15 but should still be available and work on Z16.

1 Like

Zab, you rock.

I had forgotten about Caffeine.

It's been a while since I used VLC, didn't it have an option to "Disable screensaver"?

Yes, but I believe that it is supposed to be enabled by default. The OP can check if it is enabled by going to tools > preferences and then in show settings select "all". Then scroll down and click on video and the on right check if it is enabled.

2 Likes

Hi all,

OK, so : It happened that I installed VLC with synaptic (with all the dependencies of course).
But surprisingly, according to VLC official webpage, this is not the recommended method.

I then uninstalled vlc with synaptic and installed it with snap :
sudo snap install vlc

And the problem is now solved.

3 Likes