Zorin Core 17 - Layout ignored

When official image of Zorin OS Core 17 was available, I installed it on my VM.
Played around with it and shut it down. Today I started the machine again, and to my surprise the layout looks like Fedora layout.
OK, I think to myself maybe I have chosen this layout when I played around with it. So I start Zorin Appereance and I see the first layout is selected.
I change to a diferent layout, nothing happens.
I try all the other layouts, nothing happens.
It seems tha layouts are broken.

Log messages:

12:54:14 pulseaudio: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
12:54:13 gdm-session-wor: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
12:54:11 kernel: [drm:vmw_msg_ioctl [vmwgfx]] *ERROR* Failed to open channel.
12:54:07 systemd: Failed to start Application launched by gnome-session-binary.
12:54:05 gdm-session-wor: gkr-pam: unable to locate daemon control file
12:53:49 pulseaudio: We were woken up with POLLIN set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
12:53:49 kernel: [drm:vmw_msg_ioctl [vmwgfx]] *ERROR* Failed to open channel.
12:53:48 systemd: Failed to start Tracker metadata extractor.
12:53:47 kernel: [drm:vmw_msg_ioctl [vmwgfx]] *ERROR* Failed to open channel.
12:53:47 systemd: Failed to start Tracker metadata extractor.
12:53:46 kernel: [drm:vmw_msg_ioctl [vmwgfx]] *ERROR* Failed to open channel.
12:53:45 gnome-session-b: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
12:48:34 kernel: [drm:vmw_msg_ioctl [vmwgfx]] *ERROR* Failed to open channel.
12:48:05 pulseaudio: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
12:47:49 kernel: [drm:vmw_msg_ioctl [vmwgfx]] *ERROR* Failed to open channel.
12:47:40 systemd: Failed to start Application launched by gnome-session-binary.
12:47:39 pulseaudio: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
12:47:36 systemd: Failed to start vboxadd-service.service.
12:47:32 systemd-udevd: vboxuser: /etc/udev/rules.d/60-vboxadd.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxuser".
12:47:31 kernel: [drm:vmw_host_printf [vmwgfx]] *ERROR* Failed to send host log message.

Can you try running:

/usr/bin/gjs /usr/share/gnome-shell/org.gnome.Shell.Extensions

Also, does this happen even after restarting? Or does it break after doing something in particular?

Maybe You could try a simple Restart of the System. Or You could try to reinstall Zorin Appearance. For that open the Terminal an type:

sudo apt reinstall zorin-appearance

Last thing I remember doing was trying to change Themes and layouts, and that worked back then. Then I shutdown the VM until today.
I restarted the VM today many times, the layout is not coming back at what it is set in Zorin Appearance.

runing your command did nothing. the command finished. I restarted the machine, tried Zorin Appearance and nothing is changing in Layouts, the Themese change when I chose Light or Dark, so it's not completly broken, it's just the layouts.

done the reinstall, nothing changes when selecting layouts.

Check the integrity of the downloaded ISO, as something may be wrong with it. Something else may have gone wrong during the install or some update, so I would suggest throwing away this virtual machine and start over.

Typically I create a snapshot on my first boot, once I've confirmed everything works, so that I can revert back to it as needed, or clone it.

I will try to reproduce the steps tommorow after fresh install on the VM.

1 Like

I now have the exact steps how to break the layout.

  1. Install fresh Zorin OS 17
  2. run command: sudo apt install make perl gcc
  3. Open Firefox: https://www.citrix.com/downloads/workspace-app/linux/workspace-app-for-linux-latest.html
  4. Download the Debian package: Citrix Workspace app for Linux (x86_64) (258.33 MB)
  5. After download, double click on the icaclient_23.11.0.82_amd64.deb file and install the package
  6. Reboot
  7. Observe broken Layout.

So it seems that with the Citrix Workspace app, the layout gets broken.


When you install it through double click, it will automatically install something called App Protection Component. However, when you run the installer through the command line you will be prompted to choose whether or not to install this:

sudo dpkg -i icaclient_23.11.0.82_amd64.deb


When I chose not to install this, the layouts continued to work normally. I don't know what it's happening underneath that would cause the layouts to break but it seems that it's specific to this software.


1 Like

Not sure if I need to use App Protection Component with my client/customer. The idea was to use this for work, but now I am again stuck on Windows because of this.
Ohh well, atleast we figured out what the problem was.

Yeah, without knowing more about what it does or how it works, I would probably do the same. You can still use a dedicated VM with another OS just for this, though, maybe running under Linux Mint?

No worries, for private use I can still use Zorin.

1 Like

Just a quick update on this topic, so it's affecting other apps too:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.