Zorin doesn’t write to my external hard drive right away

Hello, I’m dualbooting Zorin OS and Windows 10 on the same machine. What I’ve noticed is that Zorin can’t edit my external hard drive or Windows straight off the bat. I have to mount them with Windows, switch to Zorin and then it works like a charm. Anyone know a fix?

Can you also give more information about your Drives, CPU, .etc? It can help us A LOT.

How to give Drive Info:
sudo apt-get install inxi ←(Installs Inxi)
inxi -d ←(Tells Inxi to show your Drive Information)
Copy the output, and send it here.
:+1:

What is Inxi:
Full-featured system information script Inxi is a system information script that can display various things about your hardware and software to users in an IRC chatroom or support forum. It runs with the /exec command in most IRC clients.

If you want to remove Inxi for some reason:
sudo apt-get remove inxi ←(Uninstalls Inxi)
sudo apt autoremove ←(Removes Unused Dependencies)

Hope this is detailed enough :grin:

2 Likes

This is an interesting one... I would have thought a Permissions issue for the external drive; such that giving yourself ownership would resolve (replacing $USER with your actual computer username and 'nameofdrive' with the external drive name):

sudo chown -R $USER:$USER /media/$USER/nameofdrive

But if booting windows enables Zorin to have access- that is Weird.
Is Fast Startup disabled on Windows? Is Secure Boot disabled in EFI settings (BIOS)?

1 Like

Yes, it is weird, Windows shouldn't affect anything on ZorinOs.

Sure thing, I’m using an Acer Nitro 5 AN515-51, 256 GB of SAS SSD storage, an Intel Core i5 7300HQ, 8GB of DDR4 RAM and an nVidia GeForce GTX 1050. Hope this helps!

Secure boot is disabled on the BIOS, and boot mode is UEFI. As for fast startup, I don’t know, but all I can tell you is that I haven’t touched any of the default settings.

On Windows OS, it is in the Control Panel under Power Settings, I think. I am sorry but you may need to do a net search for more specifics. I do not touch Windows often enough to have it all memorized.

You may find the second post helpful:

I turned off fast startup, but the problem persists. Even worse, my PC won’t even start Windows properly now. It’s just a black screen.

Update: I managed to get into Control Panel and turn fast startup back on.

To run Linux on dual boot, Fast Startup or Fast Boot must remain off. Fast boot locks the drive, preventing access.
Turning Fast Startup off is normal and it should not prevent Windows from starting or lead to a black screen.

Fast startup was turned on by default and Linux was still working fine. It should be noted that I didn’t have to configire GRUB after installing Zorin, it just worked straight out of the box.