Zorin doesn't recognize my GPU?

Hi.

I was an Ubuntu user and installed Zorin OS just for the heck of it. I really love the look of Zorin and I might just stick to this instead, plus it being Ubuntu-based really helps because I'm familiar with Debian-based distros.

My NVIDIA drivers seem to work fine but the OS isn't displaying the actual GPU name. I have a RTX 3060 Ti and Ubuntu correctly displayed the GPU name.


image

What version of Ubuntu were you using? Zorin 16 is based on Ubuntu 20.04.

Ubuntu 22.04

20.04 sort of predates the release date of my card, is that why? The card is working fine though, the games I tried work as they should.

I suspect so. A bit like Simple scan, got renamed Document scanner and worked out of the box with newer versions of Ubuntu and Fedora Workstation of which I neither like! I'm currently running Devuan and the scanner driver for Canon has a limited interface so I use proprietary Vue Scan from hamrick.com

I also have Nvidia 3060 and it fails to ID the name, too. Another user posted the same experience, and all three of us experience normal performance.
Not sure why it fails to provide the right I.D., though thankfully, it is a very minor issue.
Running the query

nvidia-smi --query-gpu=gpu_name --format=csv

Provides it without any trouble...

nvidia-smi --query-gpu=gpu_name --format=csv                              ─╯
name
NVIDIA GeForce RTX 3060

2 Likes

I tried Screenfetch (as opposed to Neofetch in the OP) and it picked up the proper GPU model.

Is this also an issue on Mint? I haven't tried it but it's also based on 20.04 I believe.

1 Like

Interesting... I just tried this out and got the same result as you.
I generally prefer Neofetch. This makes me wonder...

Both are being actively supported. You can check them out by doing a search in github.