Zorin/Gnome Calendar not displaying dates row in week view

Hi everyone! It's my first post here, and I've tried looking for someone else with this issue, unsuccessfully.

I'm having this very weird issue where the default calendar app (GNOME Calendar package, not flathub) doesn't display the dates row (where you'd usually see the day number and week day). I've tried switching between light/dark mode, reinstalling the app, switching region/language (to other English variants), but it isn't working. Notice that it does show properly in the notifications panel/widget and in other views (month/year).

Is there a setting somewhere I can check? Thanks!

System info:

I'm on Zorin OS 16 Pro. Region/Language is English (UK).

inxi output:

CPU: Quad Core 11th Gen Intel Core i7-1185G7 (-MT MCP-) speed/min/max: 640/400/4800 MHz Kernel: 5.10.0-1045-oem x86_64 
Up: 3d 15h 05m Mem: 6137.6/15723.5 MiB (39.0%) Storage: 953.87 GiB (5.1% used) Procs: 358 Shell: zsh 5.8 inxi: 3.0.38

And a few screenshots so you understand what I'm talking about:

Showing in notifications

1 Like

Can you please open a terminal and run

sudo apt install --reinstall gnome-calendar

sudo apt install gnome-tweaks

Log out and in, and test gnome calendar. It it is still not working, open Tweaks from the app menu and go to the Extensions tab.
Disable all gnome-extensions. Then test Calendar. If it works, can re-enable extensions, testing calendar as you go, until you find which one is interfering with the app.

If problem persists after reinstalling and disabling all extensions... I'm not sure yet. :expressionless:


Thanks @Aravisian ! I tried all that and nothing changed (the problem still persists with all extensions disabled). I had already installed gnome-tweaks as I've been trying for the last few days to find a setting hidden somewhere in some text file that would cause this.

An update on other failed attempts: Installing GNOME Calendar from flathub also has the same problem (it's still themed from Zorin), but installed from snapstore it doesn't (it's got the default gnome theme). I think this confirms the problem is somewhere in Zorin.

I forgot to mention I'm using the "Large text" accessibility option, although even disabling it has no effect. I'm at 100% scale for screen, and happy to share any other settings anyone might find relevant.

1 Like

Fractional scaling is known to create oddball issues across Ubuntu and Ubuntu derivatives...
This may not apply in your case.

So, Snap works properly but Flatpak and .deb don't?

1 Like

Thanks @Aravisian !

Yes, hence why I mentioned the large text thing, but I've got fractional scaling disabled, and am at regular 100%. Also to note I have tried 125%, 150%, and 200% without any changes there. Like you said, it doesn't look like it applies here.

Yeah (assuming by .deb you mean apt, since I haven't downloaded any deb from anywhere). The problem with the snap version is that the theme is the default GNOME and ignores my dark mode, for example. Since the flatpak version keeps the dark theme, I imagine that's in the origin of the problem.

Yes, all apt packages are .deb packages.

All Snap packages do this. Snaps are sandboxed - it's a headache...

This implies a missing or corrupted dependency somewhere...


Flatpaks are also sandboxed, they still follow your theme. They generally take up a lot of space. If you care about performance, management and overall usability, you will experience a lot of PAIN.

Kedric, sorry - yes. I forget this because Zorin includes flatpak themes for flatpaks allowing them to be themed with the system.

1 Like

Thanks @Aravisian and @Kedric !

Assuming I'm the only person with this problem, what can I do to help figure this out? It's been over 10 years since I last had to recompile a Linux kernel, but I'm happy to go "low" to try and help out. This was a fresh Zorin OS Pro 16 install, BTW. I had installed Core on another computer with this problem, but since it was a VM and I was mostly experimenting, I didn't care much.

Also, should I be logging this somewhere else instead, like GitHub?

1 Like

I would be hard pressed to think the kernel is involved. Gnome-shell? Sure.
You might reinstall it:

sudo apt install --reinstall gnome-shell zorin-os-desktop

As a viable attempt.

Sorry @Aravisian , I didn't mean to imply the kernel was involved, only that I would be comfortable doing something more than running sudo apt commands.

I did just reinstall gnome-shell and zorin-os-desktop, to no avail.

As well as gnome-calendar, earlier. At which point - I am stumped.

Thanks for the great suggestions! So what can/should I do next? Email Zorin support directly? Open an issue in some GitHub repo?

I think both or either of these are valid options. I would assume you are not the only one experiencing this.
If you were, I would go in the direction of reinstalling Zorin OS.

1 Like

Alright, I got a reply from Zorin acknowledging the bug and it's already been fixed! Just updating Zorin Base via Software Updater worked.

Thanks everyone for the help!


They make Fast Fixes. I just commented on this in another thread, too...

Wow - it was the theme. That did not occur to me that the theme was causing it... much less since flatpak Zorin Themes are included and it worked in Flatpak.

Noted for future reference...

1 Like

For reference, the fix is in this commit: Fixed issues with Gnome Calendar, Todo, and text selection in Evince … · ZorinOS/zorin-desktop-themes@e993e2e · GitHub

Also, it didn't work in flatpak, only in snap (where the theme wasn't applied).


I opened it and :roll_eyes: then quickly closed it :sweat_smile:
I have to admit my limitation.