Zorin hiding files and directories?

I've been using ZorinOS for about 2 weeks and I've found an annoying problem. It's generally very good other than this.

I use it as my work PC and we use Slack and Zoom. I've noticed that for example in Slack if you go to upload a file, much the home directory is hidden. For example, my "develop" directory does not show. It only shows Documents, Downloads, Music, Pictures and Videos and no other folders. I tried the "+ Other locations" option but develop is hidden as well as other folders.

In Zoom, I tried to add a background image but had a similar problem. In fact, no jpg files could be found. It's like the dialog box is crippled. The normal directory browser shows everything. Where is the magic setting that turns off this broken functionality?

1 Like

In file manager press CTRL + H

4 Likes

With my knowledge on Linux, I concur with Michel CTRL H will bring the hidden out from the shadows, and into the light for your viewing!

3 Likes

While CTRL+H did actually show hidden dot files. It still failed to show the other directories which aren't hidden in the normal sense. It seems to be being filtered. Any ideas?

The dialog on the left is the filtered view after CTRL+H. The right view is the full list of whats in it. As you can see, some directories are not even showing.

The Gnome Dialog only shows what is in the XDG_Directories.
Which applications are you opening this dialog in?

Are you attempting to share files from your develop directory to slack or zoom? Usually it will give a dialog to browse for the files you want to include as an attachment. Slack and zoom, while can access your files through the said dialog, are not full fledged file browsers. They may be limited in showing files based on type and all programs are limited based on permissions.

How did you install slack and zoom? Did you sudo them in... do they run with system, your user or root permissions. Can you open the properties of the desktop shortcut, click the permissions tab and check that owner has full permission (rwx) and the group should be your user name, group should be read (r) and other should be read as well.

I use slack, choose and zoom without these issues. I'm wondering if you change something or if you aren't a part of the group that can view those files from the apps.

1 Like

Zoom and Slack currently

Could it have something to do with being flatpak version?

How do I locate the shortcut link for the app in the zorin menu?

Good possibility. Try downloading and installing the .deb:

(choose ubuntu, 16.04+)

when both are downloaded, double click to install.

If you need root privilege, open terminal and type:

sudo -i
nautilus

Then navigate to your download folder and double click the zoom and slack deb packages.

Be sure to uninstall the flatpak's first.

1 Like

I have solved the issue.

When I installed Slack and Zoom the Software Centre prompted me to install it from there which uses flatpak images.

It seems that's the issue. I installed an app called flatseal - an app that allows users to manage flatpak app permissions. This allowed me to widen the permissions to all user files. Problem solved!