Zorin Hotspot not visible on other devices

I was previously using Ubuntu 20 and hotspoting from laptop (Asus UX305) worked just fine. I recently moved to Zorin Core 16 and since that time I can't use my laptop as hotspot. Network Manager seems to work just fine, but no other device (android phone, kindle) sees the network or it shows up for a second and disappears.
I tried doing it through Settings->Turn on Wifi Hotspot, I tried creating hotspot through Network Connections editor, I tried using ap_create module, all with same result.

Any ideas would be appreciated.

This topic has quite a few different suggestions in it:

I am not sure if any apply to what you are seeing on your screen.

Thank you.
I've seen this topic, but my case is different. It's not that I cannot activate the hotspot. Problem is that, once activated, no other device detects it. :confused:

You activated hotspot on Zorin OS... and no other device sees it.
Have you set wifi for your hotspot to 2.5Ghz and not to 5Ghz?

Huh! That's interesting. Changing band from automatic to 2.5 actually did the job. Or changing the channel from automatic to some arbitrary value (which I did for no apparent reason lol). Anyway, one of these two solved the problem.
Thanks a lot, @Aravisian !!

1 Like

OK, I think I spoke too soon.
Yes, it did work yesterday, it worked quite nicely actually. But today the networks seems to disappear every hour or so, and I need to restart the hotspot couple of times to make it work again :confused:

Did a reboot reset the wifi hotspot to default settings?

Hi, I have faced the same problem.
In my opinion, u have to change the wifi setting for your hotspot to 2.5Ghz or 3.5 Ghz.

No, reboot doesn't seem to affect settings.
All in all, hotspot seems to be very unreliable, it worked for most of afternoon yesterday, but in the evening it dropped again and hasn't been working since. It's either not visible on my phone, or it appears, but when I try to connect, it refuses to do so.

@samdenial I did set it to 2.5 (I don't have option to set it to 3.5, only 2.5 and 5) and it doesn't seem to change too much.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.