Zorin install might be beat up

Pretty sure I messed up the install, so mostly I just want to know what my next steps are.

My gf gave me her old laptop as she got a new one (I will put the specs below) and I proceeded to download the latest Zorin Lite. Everything was going smoothly until I ran into an error that was looping (picture will be posted).

I looked far and wide for a solution but mostly found Ubuntu and Mint forums with similar issues so I went and modified the parameters to include "pci=noaer".

After, I restarted the computer and got to the Welcome screen of the installer, but it froze. I waited a solid hour before restarting and now it won't get past the HP / Zorin logo. Where should I go from here? I would say I'm decently experienced with Linux, but usually the OS's I install on my VMs work without a hitch like this. Any advice and criticisms would be appreciated.

Did you disable Secure Boot in BIOS Settings?

Are you dual booting with Windows or overwriting WIndows? If so, did you disable Fast Boot in Windows control panel > Power options?
And shut Windows down fully before booting the Live USB of Zorin OS...

In Your BIOS Settings, are you set to RAID or to AHCI (You should use AHCI)?

1 Like

I disabled Secure Boot

I am overwriting windows, though I did not disable Fast Boot. I was a bit tipsy and just went straight for Restart Now in Settings > Recovery

I couldn't find the setting to change to AHCI.

How screwed am I?

What is your exact make and model notebook?
I know that some HP notebooks disallow changing from RAID to AHCI because those machines are intended only for Windows OS.

HP Notebook - 15-bs015dx

This is what I found. I see others putting Linux on here, was thinking of trying another distro if I couldn't get Zorin to work.

Well, you tried noaer, have you tried pcie_aspm=off?

Tried it and the same issue as before; it just brings me to the Welcome screen of the install but it's blank.

In the LiveUSB, open Disks from the app menu and look at your drive and partition.

Is it accessible?
What filesystem is it formatted to?

In the setup of the installer, there's an option to download updates as the installer works... uncheck that and it should go through. You can install the updates after you've got a stable desktop.

Don't set up any network connections / WiFi until you've reached a stable desktop.

I ran into that issue on the last two laptops I installed Zorin on.

1 Like

I was only able to get to that step on my first run, and since I was at my GFs and she doesn't know the WiFi password off the top of her head, I went ahead and did it without installing the updates and without a WiFi connection.

I then ran into that issue that I screenshot up in my Original Post. It kept looping this error and hanging so I brought it home and tried the installation again, and here we are.

Regardless of changing the parameters and the solutions I've tried, the furthest I can get is a blank, unresponsive Welcome page.

Could you elaborate how to find Disks in an app menu? The furthest I can get on the laptop is the blank Welcome page of the installer.