Zorin Installation from Scratch

I had a problem installing the Zorin OS. I kept on getting Error 5 IO Error.

I ran the following diagnostics

  1. Changed the installation USB. This had no effect
  2. Ran nvme-cli and smartctl both reported that nvme was fine.
  3. Checked disk health from BIOS, no error reported.
  4. Installed Fedora and Ubuntu server this installed without issue.

PC: Asus OLED 14
SSD Info:

20: PCI 300.0: 0108 Non-Volatile memory controller (NVM Express)
  [Created at pci.386]
  Unique ID: svHJ.HH1M6tPWMm8
  Parent ID: Rtk9.JhR1dXh1J9E
  SysFS ID: /devices/pci0000:00/0000:00:02.4/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: storage
  Model: "Intel Non-Volatile memory controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0xf1aa 
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x390f 
  Revision: 0x03
  Driver: "nvme"
  Driver Modules: "nvme"
  Memory Range: 0xfcd00000-0xfcd03fff (rw,non-prefetchable)
  IRQ: 53 (no events)
  Module Alias: "pci:v00008086d0000F1AAsv00008086sd0000390Fbc01sc08i02"
  Driver Info #0:
    Driver Status: nvme is active
    Driver Activation Cmd: "modprobe nvme"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #41 (PCI bridge)

I've installed Ubuntu 22.04.3 LTS , added the zorin-os ppa and installed the zorin desktop sudo apt install zorin-os-desktop -y
However, my desktop looks like this

Not sure, whether just adding the Zorin ppa is a proper way to install. Better would be to download the .iso and really install from the scratch.

What about the the live version - did it work?

I ran the live installer, I created the bootable USB using balena etcher and verified the checksum intergrity.

The live installer fails towards the end with the error [Errno 5] - Input/output error

There's no issue with my usb drive or my nvme. I used the same usb and nvme device to install ubuntu and fedora.

I'm able to run a a live session without issues however the installer fails at the end while it copies the files

Did you try another USB Stick? Had a similar problem some weeks ago, it was the USB...

I've tried a different USB sticks. I decided to try Zorin OS 16.3, installation worked without any problem. Same machine same USB same balena etcher.

I'll keep using 16.03 for now.


OK, that`s interesting. Which Ubuntu Version did yu install successfully?

Don`t forget to mark your solution as solved, so everybody can see you found a solution

I successfully installed Ubuntu 22.04 Server and also I was able to install Zorin os 16.3. I attempted installing Zorin OS 17 again and it still failed with the IO Error.

I'm going to keep using 16.03 until I can do an update to 17

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.