Zorin installed but won't boot

Back here after family health emergency and multiple catastrophic hardware failures, now trying to install Zorin Lite 16.2 on my mum's Lenovo laptop, which finally stopped booting Windows this week. (Typing this from Zorin Lite on her old HP laptop)
After trying (and failing) to boot/repair Windows with things like WinRE, Windows 11 installation media and Hiren's Boot CD PE, I used Zorin Lite on USB to boot and copy any files she wanted to keep to an external HDD, and then to install Zorin to the hard drive (which I've wanted to do to this laptop for a long time) .

(Zorin install options: connect to internet, allow updates & third-party, erase & use whole disk).

The process seemed to go OK but then upon automatic reboot, I got these errors:

[0.217683] x86/cpu: SGX disabled by BIOS.
[0.318091] BIOS error (bug): Could not resolve symbol [\_SB.PCI0.URT2], AE_NOT_FOUND (20210730/dswload2-162)
[0.318123] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/ps object-220)
[0.318205] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PC10.SPI1], AE_NOT_FOUND (20210730/dswload2-162)
[0.318226] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/ps object-220)
[0.683653] integrity: Problem loading X.509 certificate -65
[5193.871599] blk_update_request: I/O error, dev sda, sector 1331176 op 0x0: (READ) flags 0x0 phys_seg 1 prio class 0
[5193.871709] Read-error on swap device (8:0:1331184)

It just stayed on that error screen so I pressed the power button, some more lines appeared but quickly disappeared before I could see what they said, then "Please remove the installation medium, then press ENTER".
I removed the USB and pressed enter.
The PC powered off. Upon restarting it, I got this:

Default Boot Device Missing or Boot Failed.
Insert Recovery Media and Hit any key
Then Select 'Boot Manager' to choose new Boot Device or to Boot Recovery Media

I re-inserted the USB and hit Enter.
The boot manager comes up and the internal hard drive is not even listed as an option, just the USB (EFI USB Device) and network (EFI PXE Network). (Before, when Windows wasn't booting sucessfully, the hard drive was still listed in the boot manager.)

I hit enter for USB, got the usual start up stuff, but then the same errors as above, plus an additional line containing the phrase:

ata1 soft reset failed

That line repeated a few times but before I could see everything it said, that all disappeared and the computer proceeded to checking Zorin's md5sums.

I thought maybe Zorin hadn't atually installed so I decided to restart the whole Zorin install procedure.

But when it gets to the "installation type", it says:

This computer currently has Zorin OS 16.2 (16) on it. What would you like to do?

  • Install Zorin OS alongside Zorin OS 16.2. (16)
  • Erase disk and install Zorin OS
  • Something else

So apparently Zorin is installed already. Now I don't know what to do. Erase disk and re-install anyways? Something else? Any thoughts?
PS Secure Boot is disabled, not sure if that makes a difference. Also the hard drive seems to be working fine.

It does - I was about to ask you to double check that due to:

You also said:

I have some doubts. You said that Windows just stopped working and with the current issue you are facing, it looks a lot like bad sectors or a bad boot EFI partition.
Have you run S.M.A.R.T. test on the drive?

These show Drive Hardware failures.

In the BIOS settings, is it set to AHCI or to RAID?

You might try boot repair from your Live USB:

Lastly, these warnings can be ignored as harmless:


I think this line appears on my lenovo laptop aswell everytime i start my laptop but just for few secs and it doesnt stop any process. So i never bothered to fix it but id really appreciate if anyone looked into this.

You can check your BIOS Settings for an option to enable SGX.

Is it useful or better left as is ? i mean i still wouldnt bother if its harmless.

It may be useful, primarily if dual booting on WIndows.
It is Intel Software Guard Extensions, which you can google for more info. In actuality as an average Linux user, you most probably can roll on without it just fine. But if you want peace of mind for whatever, you can enable it.

Thanks for the reply.

Re hard drive:
I did some kind of hard drive check (I think SMART but I'm not 100% sure) from the utilities in Hiren's Boot CD PE and the results were all OK. I also assumed the HDD was ok because I was able to open & use files from it OK when booting from USB.

I've got the errors from when Windows wouldn't boot successfully.
The boot would start but then give a Microsoft blue screen with:
It would then continue and give a different BSOD with the error
0xc0000185, with below options like "F1 to enter recovery mode" (but it never worked).
My puny research on those error messages seemed to indicate boot problems, not HDD problems but I am not an expert.

A few minutes after my original post, I found the Boot Repair program in the Live USB and I'm running that. When it asked if there was RAID on the hdd, I said no. (That's just my best guess. It's a cheap consumer laptop belonging to my tech-hindered mum, so I assume it wasn't RAID.)

Boot Repair is still running (I chose the "Recommended repair" option).
"Purge and reinstall the GRUB of: sdb2 (upd). This may require several minutes..."
It's been like this for ages, I will post again when it finishes.

1 Like

You will want to check in your BIOS / EFI settings if set to RAID or not.

This also suggests bad EFI partition. Which gives us three indications:

  • Grub not working (It needs an accessible file on the EFI partition
  • Possibly : I/O error, dev sda, sector 1331176 op 0x0

Solution could be to wipe the EFI parition and create a new one.

I'm still in the middle of Boot Repair, which has given me a series of commands to run in the terminal. They seem to be about completely removing GRUB & GRUB2. I'm on command #3 out of 7, and it's taking forever.

If this doesn't work, I'll try that advice on wiping the EFI partition.


Result at end of Boot Repair:
I'll have to finish dealing with this tomorrow.

Gday @4box

Welcome back, i hope all went as well as possible with the family emergence.
A few red flags:

I assume this was another machine?

Now you've taken procession of your mum's laptop? :slight_smile:

Most hardware has a 5-10yr life span,

First i would start again.
Assuming the hardware is ok for now.
I would reset the BIOS back to default.
Next check the BIOS is up to date ( firmware/drivers) ( you may need to flash the BIOS, Some BIOS's have an internal option in "Advanced" to update) Check the manufacturers website on "how to".
Next reset CMOS, again check via manufacturers website, "How to" ,
Next double check your download;

I recommend using "Rufus" to create the bootable usb stick.
Once the BIOS is updated.
Set the BIOS boot priority, to boot from the usb stick. shutdown the machine, insert the usb stick & start the machine.
Hope this helps.

1 Like

Here's the latest.

Ran Boot Repair yesterday, ending with error message posted above. Today I started up the machine, got a Zorin "boot menu", with 3 options: Zorin, Advanced Options for Zorin, UEFI something. I chose Zorin. (Is this menu new? I don't get it on the Zorin Lite machine I installed in December.)

Boot seemed to start, with Zorin logo flashing like usual.
But after a minute or two, thrown into text mode. Again those messages about ACPI BIOS error bug and AE NOT FOUND etc, followed by:

[2.130791] integrity: Problem loading X.509 certificate -65
Unable to find a medium container a live file system
Attempt interactive netboot from a URL?
yes no (default yes):

I don't know if that provides a further clue as to where the problem lies.

@Ocka Thank you.

Re hardware failures, yes other machines (hard drive cable on one, fan on another), but now I'm wondering if this Lenovo's issue might also be hardware.

For a long time, my mum's Lenovo under Windows (10, then 11) has been slow and overworked (CPU often at 100%, HDD at 100%, RAM at 95%) with a gazillion background processes. But it worked just fine the times I tested with a live Zorin Lite USB. Nothing I could do from within Windows truly fixed the issue, so I planned (with her consent) to get Zorin Lite up and running with everything she needs on her old Windows 7 HP laptop, before then turning to the Lenovo and doing the same with it, because I thought it was a software/OS issue that would be resolved by wiping Windows and installing another OS.

In the meantime, said health and technical emergencies came up, delaying the transition to ZLOS. Then this boot failure issue came along, forcing my hand to try something ASAP.

Re ISO integrity, I verified the checksum with GtkHash and Zorin itself performed its own integrity check upon live USB startup. Both were OK.

Re flashing USB, I first tried with Etcher but the result was unbootable (I double checked the ISO integrity at that point). Then with Ventoy and it booted just fine. I think Rufus is Windows only but I might see if I can give it a try (although per above, Zorin performed its own successful integrity check on the Live USB.)

I will wait for forum feedback on the latest error message, read up a little on EFI/UEFI and BIOS and come back tomorrow before attempting anything.

Thanks everyone for your input.

This is the grub menu and it can appear if you have more than one OS installed or if the Install needs Recovery (Advanced Options for Zorin).

@4box , you currently have:


The Hard Drive is failing, there is no doubt.

Well I fired up Hiren's Boot CD PE again, and again used the hard drive diagnostic tools.

At first glance, everything's OK (like the first time I looked). "SMART: Passed", "Health Status: OK", big green ticks all over the place.

So I looked at the details and ran some of the more in-depth scans (inc. one that lasted 13 hours!)

Gsmart Control Summary

GSmart Control
General tab: Overall Health Self-Assessment Test: PASSED (which is all I looked at last time)
But in the Attributes tab, three highlighted in red:
Reallocated sectors count, Reallocation Event Count, Current pending sector count,
Those attributes and a few more are lised in the "Type" column as "pre-failure", and many more as "old age".
Also issues in red in the Statistics and Error Log tabs.
Short self-test: Test aborted, cannot parse smartctl output. No ATA sections could be parsed.

HDDScan4.1 Summary

State: Green
Attributes: All green except for exclamation marks in the same three attributes as GSmart Control.

HD Tune Summary

Health tab: Reallocated Sector Count in yellow, but status "OK". Status for all attributes "OK". Overall health status: "OK".
Error scan: 6.8% of blocks damaged.


Western Digital Data Lifeguard Summary

Western Digital Data Lifeguard Diagnostics
SMART Status: PASS, big green tick.
DLGDIAG Extended Test:
After 2 hours, "Test stopped with errors. Too many bad sectors detected."

So they all say that, overall, the HDD is fine but in the details and scans there are issues like bad blocks/sectors.

I'm hoping against hope that there is some way I can go on using this hard drive (route around bad blocks?) as I can't replace a hard drive myself and I haven't found yet a computer repair technician I trust to get the job done right.

I might just use an OS that can run from RAM (e.g. Puppy) and store everything in the cloud until I find a decent repair tech.

Thanks to everyone for their help and suggestions.

PS I also ran Gparted and confirmed there is an EFI partition (/dev/sda1, Name: EFI System Partition, fat32, Size: 512 MiB, Used: 5.99 MiB, Options: boot, esp). And those AE NOT Found and X.509 certificate messages still popped up even when booting from GParted Lived USB (Ventoy).

This is an ACPI tables issue and can be ignored. It is not dangerous, just annoying.

What it looks like, to me... Is that during installation, the installer wrote to a block or sector that initially read as "good" that went "bad" as soon as it was written on.
That is a big part of why I am leaning the way that I am. I would love to be wrong about it. No one wants you to have to buy a new drive and go through the hassle of replacing it.
That said:

Believe in what you can do. You may not know all the steps to replace a hard drive but you can do it. You are capable of learning and being careful. The only thing left to hold you back is: Not wanting to deal with that kind of task (Which I Understand 100%, especially on a notebook computer.)

Thanks. Yeah, I've never opened up and changed internal hardware before but I'd be a bit more willing to try it on a desktop. There's no obvious "hard drive bay" on the bottom of the laptop, and without an appropriate screwdriver to take off the entire case, I can't even begin to see how complicated a job it would be.

But I'll start watching some videos and see if I can find the blueprints for this model.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.