Zorin installer stuck on cpu softlock

I am new to Zorin, my distro of choice used to always be Ubuntu but I've had issues in the past with it so i'm now switching to ZorinOS. The computer I currently have (HP Pavilion Desktop TP01-2xxx) has always had issues installing anything except Windows, but my other HP computers have done it fine. I put Ventoy on my USB 3.0 2TB SSD, dragged the Zorin 16 Core r4 iso into it, and tried to boot from it. I set it to safe graphics mode, ensured that it was on nomodeset (not noacpi or nolapic since that seems to cause issues) and booted into it. After about 10 minutes it seemed to be going well but when I pressed esc to leave the splash screen I saw the logs looping a message with RIP, RSP, RAX, RDX, etc. codes and I have no idea what those are, they seem like nothing out of the ordinary. There is also a message saying "watchdog: bug CPU #8 is softlocked" or something like that. I rebooted the installer after about 20 minutes and was given the same thing, but with cpu #3 this time. I've now been waiting over half an hour and nothing seems to be working, the keyboard won't give any output and the ssd sounds like it's repeating a process over and over. I have also tried using a usb but that was not only unbearably slow (thank you, usb 2.0) but also ended in a kernel panic. is there any way to turn off multicore, is that even my issue, if not how do i fix it?

PC specs:
Intel Core i7 11700F 16 cores
AMD Radeon RX580
256GB HDD, 1TB Internal SSD
Windows 11 Home Currently Installed
Secure Boot off, Fast Boot off, Secure Boot keys cleared, boot order set to use external devices when available, legacy bios tried but didn't work, etc etc

Edit: I tried installing on a microSDXC card that i usually use on my raspberry pi, it would sign the md5 sums but get stuck on "deb cdrom:[iso name]/ focal main restricted; repeat for the rest of the cds in your set" and upon pressing esc the splash screen shows the ZORIN text under the oem logo while its clearly doing nothing. i had a similar issue with the usb 2.0 drive.

What this means is that the kernel is looping a task, or repetitively attempting to complete a task which is hogging the CPU and preventing other processes from running.
The watchdog daemon will then attempt to soft lock that process in order to intervene and allow other processes to run.

What this tells us is that a process is timing out and causing the loop - likely due to hardware being Locked by Windows and inaccessible to Ventoy - GnuLinux.

These are CPU registers - I am not sure what is going on there without more detailed information.

Is TPM Enabled?

Also - with Windows 11, you must ensure that you select to Shutdown Windows fully. Even though you have Fast Boot disabled, Windows 11 will make choices for you on your behalf (In order to put Windows Dominant) and will hibernate Windows rather than Shutdown fully. You have to explicitly Order It Off, now.
If Windows is Hibernating, it locks your hardware into Windows Only use.


I kept seeing things about udev or udev queue that seemed like it kept trying to run when attempting to install other distros, i think something is intervening with that service, idk i'm still pretty new to linux but just a thought. i tried booting the ssd from bios/uefi menu rather than through windows boot manager (shift-restart) after turning off tpm and made even less progress. the logs stopped after three seconds, the last few lines were saying "new usb device detected" and listed all connected usb peripherals. ten minutes later and still nothing. this is after wiping and re-burning the iso too. i could try without ventoy but it seems to be the best workaround since balenaEtcher has some issues from time to time and rufus takes a while, even on usb 3.0. at this point i've been trying for a few weeks to get any kind of linux distro working on this pc (it's the only one that has issues) and it only seems to work with distros using kernel 6.5 (ubuntu 23.10 for example). could the outdated kernel be the issue?

It could be, yes.
The necessary drivers for that machine may not be included in the kernel until 6.4 or 6.5...

Your options are varied at this point. Does the LiveUSB Zorin OS work, at all?

Generally, I would suggest getting Zorin OS installed, then upgrading the kernel immediately prior to rebooting.

However, if you cannot even install without the kernel; then the only option is to create a Custom Zorin OS .iso that has the latest kernel, then run the Ubiquity installer.

You can do this by extracting the Zorin OS .iso, unpacking the squashfs file system, mounting the necessary mount points, chrooting, installing the kernel, unmounting, and using genisoimage commands.
If you want, I can detail all that out step by step. It's... tedious.

The other option is to use a working install of Zorin OS 16 on a different computer, then install the latest kernel (It does not matter if the 6.5 kernel has issues on that computer and that build - this is temporary and the kernel can be rolled back afterward) and use that as a Clone .iso using CloneZilla or RescueZilla.

I used the original installation iso to set up zorin in a vm, then used mainline to upgrade from 5.15 to 6.5. it runs perfectly in the vm. if i wanted to put this into the ssd, do i have to use clonezilla or can i convert the virtual disk image into an iso somehow and run it live that way?

That would be great to have a tool like that incorporated into Zorin like perhaps MX Linux. That is, include a tool that allows you to create an iso image of your installation the way you want it with your apps and settings that you can then install in any machine. Yes you can do it technically with Clonezilla I think but MX Linux includes a tool that does it for the user without any special skills or drama. That would be an awesome feature to have in Zorin out of the box.


Currently I'm using Windows terminal and VboxManage commands to take the vdi of a mostly fresh zorin install (with kernel 6.5) and converting the hard drive to an iso. Once it's done I'll burn the iso to my external ssd, run zorin from that, and then use clonezilla to copy the external ssd to my hard drive if i feel it's too slow. I'll let you know what happens but i fully expect it not to work since drivers are different and stuff.

1 Like

The vdi to iso method didn't work, at this point i think i'll just stick with a vm and put zorin on one of my other computers instead. it seems like only hp pavilion computers specifically have issues like this, my mistake for getting one I guess.

Zorin OS 17 will be released before long.
Every now and then, hardware jumps ahead. It's... just computing...

1 Like

Alright so I tried to get ubuntu 23.10 onto it since it has the updated kernel, and then realized only ubuntu unity worked for some reason? Kernel panicked when i tried Kubuntu which is my default. Either way, I tried installing zorin after installing ubuntu to see if windows really was causing issues, and while the installer did boot up, it would download everything but stop at "grub could not be installed" or something along those lines. Upon rebooting i would get the grub command line, and when using boot commands it would output a kernel not activated error. The kernel doesnt seem to be the issue because I also got ubuntu 22.10 working, maybe 6.0 is the first working version here? because grub doesn't install, nothing can boot and i have to reinstall. i hav tried this with and without ventoy, both usb and ssd, different boot params (acpi=off seems to get it working) and it still has the same issue. is there a fix for this?

While it may have a later kernel, the problem with the Interim releases is that they are primarily all Beta releases, have very limited support and also tend to come pretty bare-bones. It's like launching your ship with a skeleton crew. Interim releases are not a good metric to measure against for this reason.

As I understand your situation, you are unable to install Zorin OS at all, in order to immediately upgrade the kernel after install of the OS completes.
I maintain that your best course of action is a Creating a Clone .iso of Zorin OS with the upgraded kernel.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.