Zorin installs fine, but can't boot up afterwards

That was it! Thank you. I tried disabling secure boot just for the install, then reenabling it after and it worked. Secure boot is enabled again and I can boot into either Zorin or Windows 10 with no issue. Thank you for your help sir, much appreciated

1 Like

-chuckle- I thought you tried that when first suggested. :wink:

I should have, but assumed secure boot wasn't part of the issue as I had installed and booted into Zorin 15.3 fine before without ever having to disable it. I can't explain why it must be disabled now to install, but it works and that's all that matters :grin:

Yes, this is something that a lot of newcomers forget to do, and that is disabling secure boot and fast boot. And boy does it cause a lot of problems when those settings are enabled. Too much MS BS acting like gremlins in the engine. Better to keep em off, so everybody is happy. lol

That's what I've read but I've had Linux dual boot on 4 different machines so far and this is the first time I've ever had an issue with secure boot. Really I could probably leave it off since I can get away with most of my use in Linux anyway

I tryed Pop! OS with secure boot on, the live usb wont even start. Tried it many times, so i turned off secure boot and booted live again and it was working just fine. So i retested it again, turned secure boot on and bam live usb did not want to boot.

Some distro's don't want secure boot turned on. Secure boot was made for windows anyway (if i am not wrong)

Yes, Secure Boot is specifically a Windows thing.
Microsoft "signs" or "vouches" for the security of products, allowing them to boot if Secure boot is on.
Microsoft signed most of Ubuntu, but not all. So some Linux applications will cause a crash if Secure Boot is enabled. Some Linux applications will not make it through Secure Boot at all.
Depending on what a distro comes with pre-installed, this can affect Secure Boot. And this can depend on what the Installer included due to hardware- so some package on the .iso, that would haveaffected Secure boot if you had needed it, is not installed and is not a problem if you didn't need it according to your Hardware. So it can vary quite a lot within Distro's, as well.

1 Like

SHA256 are listed for all the Z15.3 flavours on the Zorin download webpage, reproduced here:

EDIT: OK OK I now see what you mean. Everything except Z15.3 Core listed. Doh!

Luckily I kept a copy:

Zorin OS 15.3 Core 64-bit ISO sha256 checksum

307d0244433e6d2a64ba790f2164b791886f52643346c2c0f85daaaddc0f7891

2 Likes

Although my initial problem / question has been resolved, I do have a follow up one related to this somewhat.

Right now I'm currently using 15.3 with no issues. However when I boot into version 16 via USB boot stick, I can only boot in using the safe graphics option. Zorin 16 freezes on startup if I try booting in regularly. If I boot into it via safe graphics, and install, does almost guarantee that I'll have video issues moving forward? Like I'll have to use the nomodeset option for example?

Yes, it is; though this does not mean that they cannot be fixed.

1 Like

Figured, I'll leave it as is. Everything works and if it's not broke, don't fix it. Thanks for your feedback

1 Like