Zorin Lite 15.3 installer error

Hi - I tried to install Zorin Lite 15.3 on an old Toshiba laptop. I was trying to install it from a USB stick to an external SSD attached with a USB to SATA cable. It errored out on me.

I removed the internal HDD and installed the Samsung EVO 840 SSD inside the notebook and tried again. Same error.

So I tried the Zorin Lite installers option to check the Installation media, and it found two errors! No indication what they were.

So I am downloading the installer ISO (Zorin-OS-15.3-Lite-64-bit.iso) again and I’ll recreate the installation USB using Balena etcher v1.5.7.0 again.

I tried to find the old forum post with the instructions on checking the checksums for the installation media but the links to the old forum are dead, despite it being prior to 17-SEP-2020 ?

Can you say what errors you were getting when trying to install?
Odd about the group forum… it is working on my end:
https://zoringroup.com/forum/viewforum.php?f=3

Maybe this guide can help on how to verify an Ubuntu or Ubuntu derivative download:

1 Like

Checksums for 32-bit and 64-bit.

Zorin OS 15.3 Lite 32-bit, SHA256: 95e4159ebb5b532932ade79cd0c439235e726dc30c8a00036820b7a96ee2f865

Zorin OS 15.3 Lite 64-bit, SHA256: def3e85f4a0d2769bdd614c63be9d4ac9ca23355b55653e35e68625a214df847

You can download GtkHash to verify the checksums if you are using a Linux system or Windows.

2 Likes

You can find all the ZorinOS checksums on the Zorin website here:

1 Like

If you already have a linux install on another machine there are two very simple methods as md5sum is still viable. Save the iso to your Desktop then …

In a terminal:

cd Desktop

md5sum Zorin-OS-15.3-Lite-64-bit.iso

Wait about 20-30 seconds to get the result then check here:

Or use K3b which has a built in md5 checker before burning:

With regards to SSD error this might be the solution:

1 Like

Thank you @swarfendor437, @zabadabadoo , @Xanadux and @Aravisian for your responses!
@Aravisian - there is clearly a problem with my ISP’s DNS, because using a remote virtual machine I can access the old forum, but not from my machines.
Re: checksums - on my Mac I confirmed the ISO is indeed ok:
def3e85f4a0d2769bdd614c63be9d4ac9ca23355b55653e35e68625a214df847 Zorin-OS-15.3-Lite-64-bit.iso

so it is very odd that Zorin’s own live USB installer erroneously reports an error - so I’ll have to log that issue separately with them?

@Aravisian - I have a screenshot of the error I got [Errno 5] Input/output error
It’s later in the process when the installer is actually trying to write to the new, blank SSD. {image attached}

Might be a good idea to check the partitions on that new SSD with GParted.

formatted the SSD with ext4 and checked it with GParted - no errors

1 Like

but still confused. So I’m going to install Zorin on to the original HDD that the little notebook came with and see if that works or gives the same error.

@Xanadux - installed on to the original HDD with no error - even though it was attached via a USB to SATA connector. It must not like the Samsung 840 EVO for some reason?

based on another forum post I tried to install Zorin OS Lite 12.4 64 bit onto the SSD and it also crashed with Errno 5. I am giving up on the SSD on this netbook.

jp42, have you performed a memtest? You can do so from the grub menu.

Please check that UEFI is set to AHCI and not set to RAID.

Some get this error when using the balenaetcher to USB option. I always prefer to burn to a DVD disk to install. Set the speed low when burning to a disk. Fast burn or USB install can both throw errors with the medium or the input output.

Finally, ensure that your bootloader partition is on the same disk as your installation.

1 Like

I posted the prep you need to do with an SSD drive in my first post (prep’ing Samsung SSD before install with commands needed for it to take.) You should also format to Ext2 as Ext3 and Ext4 are jounaling systems that will shorten the life of the SSD. And you have to setup TRIM - only Windows does that automatically.

1 Like

thank you! I missed the prep because I am still having some DNS issues and can’t reach the old forum domain without a work around. Thanks for the tip on EXT2 as well!

Thank you for the advice on DVD vs USB. I will try to see if I can borrow a USB DVD burner from someone as all my hardware is “discless” these days… :frowning:

The odd thing about the USB installer created by balenaetcher is that it did work to install Zorin 12.4 onto the old original HDD? I am going to follow the advice of @swarfendor437 and do the prep on the SSD that I missed before…

I solved the issue with a workaround for the Samsung SSD install error:

  1. installed Zorin Lite 12.4 to the original 120GB internal HDD
  2. booted and tested Zorin = OK
  3. created a bootable Clonezilla Live USB stick
  4. removed the internal HDD and installed the 120 GB Samsung 840 SSD in the internal SATA slot
  5. reconnected the internal HDD with Zorin installed via USB to SATA connector
  6. Cloned Zorin to the internal SSD

restarted and it boots fine and much faster than with the internal “spinning rust” HDD.

This only worked because i happened to have a HDD that was exactly the same size as my SSD.

now to upgrade to Zorin 15.3! wish me luck <3

4 Likes

Well done you! Don’t go throwing the spinning rust drives out just yet! I would have the OS on SSD but /home on spinning hdd - you can’t recover deleted data from an SSD!